Jump to content
Due to inclement weather in Southwest Florida, our Clearwater support team is offline. Our other offices are available to assist you, however their responses may be delayed. We appreciate your patience and understanding during this time. ×

BSOD BAD_POOL_HEADER - mwac.sys


Recommended Posts

I know there has been a few posts here with regards to BAD_POOL_HEADER but I hesitate to steal a thread of someone else as maybe the cause of the issue is not entirely the same.

I also encountered a BSOD BAD_POOL_HEADER

Here is my Minimdump file
An interesting post on answers.microsoft can be found here

At the bottom it says:

-quote-

BugCheck 19, {20, ffffe000f57896e0, ffffe000f5789700, 4020017}

*** WARNING: Unable to verify timestamp for mwac.sys
*** ERROR: Module load completed but symbols could not be loaded for mwac.sys
Probably caused by : fwpkclnt.sys ( fwpkclnt!FwpsConstructIpHeaderForTransportPacket0+1dd )

I might suggest to open a topic on the Malwarebytes forum as there may be a known conflict with Bitdefender:
-unquote-

The .dmp file shows both Bitdefender and Malwarebytes

FWIW and I am not sure whether it is/is not the solution but I just added Malwarebytes to trusted applications within Bitdefender.
(Likely it has nothing to do with it though).

Assume MBAM developers are looking here, or should I separately report this to MBAM support?

Thanks.

=

 

 

SnagIt-21052016 144858.png

SnagIt-21052016 152942.png

Link to post
Share on other sites

Hello, mbw62--

We are actively working with Bitdefender and they're aware of these reports, so hopefully there will be a solution soon.

For now, based on our own investigation, it seems if you disable the Block port scans in network setting in the Bitdefender firewall feature, these crashes stop.

This solution has worked well for several other Malwarebytes users.

Thanks,

Link to post
Share on other sites

I have the same problem as well.

 

BlueScreenView sais it is the tcpip.sys driver. WhoCrashed showed me mwac.sys. After uninstalling Malwarebytes (Premium btw) I do not have this problem anymore. It started on my desktop after I installed BitDefender Total Security 2016. My Laptop does not have this kind of problem (Has Malwarebytes Premium and Bitdefender Total Security 2016 as well)
Both run Windows 10 x64.

I currently do not want to reinstall malwarebytes because of the possibility of the BSOD's. Please let me know when you fix this memory/driver error.

My latest dmp file:

053016-29921-01.dmp

Link to post
Share on other sites

@bdubrow

Sorry, had  to get back on this earlier, but forgot frankly speaking.

Bitdefender was a kind of interim solution for me as my usual A/V product (Emsisoft Internet Security) had a specific issue that needed to be solved by the developers.
I cud not use Emsisoft until the moment that issue was solved. It was solved last week, so I uninstalled Bitdefender. Therefore I can't tell that the issue would not come again.
=

Link to post
Share on other sites

5 hours ago, bdubrow said:

Hi Dunky13--

Did you try the suggestion outlined in post 3 above?

Thanks,

I have not because I rather have that on, than have two AV's running. Please fix it without such workarounds. Not that MWAB does not do port scans, please do, but rather prevent these crashes from happening, together with Bitdefender, fix possible nullpointers and outofbound exceptions that could possibly create this.

Link to post
Share on other sites

No problem, totally your choice. :)  

Thanks for the dump file, too!  As I mentioned, we're actively working with Bitdefender now and the dump may come in handy.

But unfortunately there's no guarantee on timing for when either they or we might have a fix available.  

Link to post
Share on other sites

Hello there! I had the same problem with Bitdefender 2016 and Malwarebytes premium. Once i stopped using Malwarebytes everything was fine, however I need the protection. I even wiped my entire drive using DBAN and tried many solutions and configurations. I even made a post in the windows7forum. I did put some minidumps before my format and some after.

I think that the users affected by this should get some extension to their licenses, as I haven't been able to use Malwarebytes for 2 months and I guess that other users where able to do so either and it looks like it has taken you quite a while to find a good solution to this.

I hope you will be able to solve this soon :) Thanks

032416-27924-01.dmp

032616-29016-01.dmp

032816-29811-01.dmp

032816-36457-01.dmp

033116-35443-01.dmp

040216-32307-01.dmp

040516-32120-01.dmp

040716-29624-01.dmp

040716-52369-01.dmp

051416-51963-01 - Copy.dmp

051516-35381-01 - Copy.dmp

Link to post
Share on other sites

  • 2 weeks later...

I want to confirm that this problem still persists since the last update MBAM 2.2.1.1043.

Using Windows 10 x64, Insider Preview (Slow Ring), I experience random Bluescreens when both MBAM Premium and Bitdefender 2016 IS are running. Getting BAD_POOL_CALLER or BAD_POOL_HEADER. Sometimes even after few minutes of a previous crash!!

Also, I did figure out, that Bitdefender does prevent the installation of the version 2.2.1.1043...

 

My problem is that there are no crash dumps created on my system. So, however, I cannot provide dumps for a unknown reason....

But my system runs great without any BSODs when Malwarebytes is completly disabled..

Please, it's 2 months ago and I still cannot use them together without facing runtime problems!

 

Thanks alot!

Link to post
Share on other sites

12 hours ago, jimi_edwards said:

Hello, I am running Windows 10 x64 and bitdefender and having crash problems too. I have tried a few fixes but this time is the last, then malwarebytes is gone and I'll be asking for a refund.

Yes this sucks very hard as I have a lifetime license for both :angry:

Link to post
Share on other sites

On 6/19/2016 at 5:03 AM, jimi_edwards said:

I am running Windows 10 x64 and bitdefender and having crash problems too. 

Hi jimi_edwards (and others :))--

To give an update on the situation, we're still investigating this and working with Bitdefender.  

In the meantime, here's a review of the various work-arounds that have been identified--doing any one of these will stop the crashes:

  • In Bitdefender 2016, disable the Block port scans in network setting in the firewall feature
  • In Malwarebytes, disable the Malicious Website Protection feature
  • Roll back to Bitdefender 2015 which has no conflicts with Malwarebytes 2.2.1.1043

We understand that this is an inconvenience and we'll let you know as soon as there's a solution.

Thanks!

Link to post
Share on other sites

Roll back to Bitdefender TS 2015.

Ever since Bitdefender TS 2016 was released I tried installing it on about 5 PC's and all had issues during installation.

So I've been using the 2015 version ever since and have had no problems.

Edited by Sonder
Link to post
Share on other sites

On 6/20/2016 at 7:29 AM, bdubrow said:

Hi jimi_edwards (and others :))--

To give an update on the situation, we're still investigating this and working with Bitdefender.  

In the meantime, here's a review of the various work-arounds that have been identified--doing any one of these will stop the crashes:

  • In Bitdefender 2016, disable the Block port scans in network setting in the firewall feature
  • In Malwarebytes, disable the Malicious Website Protection feature
  • Roll back to Bitdefender 2015 which has no conflicts with Malwarebytes 2.2.1.1043

We understand that this is an inconvenience and we'll let you know as soon as there's a solution.

Thanks!

These seem to be the only current workarounds based on the exhaustive testing done so far on my end as well. I've rolled back to the 2015 version for now (you can generate a 2015 version key on BD's central site), and it seems okay so far. 

Edited by enyceedanny
Link to post
Share on other sites

Having the same problem on both my machines, conflict between BD Total 2016 and Malwarebytes. Have disabled Malicious Website protection on MWB for time being as a workaround. We'll see.. In the end, i think I would choose  to uninstall Malwarebytes if there is no resolution...

Link to post
Share on other sites

58 minutes ago, Kevinmw said:

Having the same problem on both my machines, conflict between BD Total 2016 and Malwarebytes. Have disabled Malicious Website protection on MWB for time being as a workaround. We'll see.. In the end, i think I would choose  to uninstall Malwarebytes if there is no resolution...

hhhhhhhhh Version 2017 will come first before they fix this <_<

Time to find a good deal for a Emsisoft license :)

Edited by Cake
Link to post
Share on other sites

Kevinmw:

Bitdefender will auto-update to this latest build.  You will have to do a "re-start" for the update to install.  My update came down two days ago.  I have turned on the Port Scan blocking in BD, and so far no issues.

Hope this helps.  Have a great day.

Regards,
-Phil

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.