Jump to content
npmaylesby

Google Chrome block with new Trusteer Rapport

Recommended Posts

I can't run this file.

I am on Win 10 and right clicking I see no option to run as admin and  I do not see any way to re log in as admin

Please help

Share this post


Link to post
Share on other sites

OK, dcmargo, if you can reboot, and then check.  If it still breaks, then you'll need to disable those settings again.  I had hoped that Trusteer had also pushed out a new update today.

Share this post


Link to post
Share on other sites

You default account should have admin privileges.  If you are already logged in as admin, then you may not see the prompt.  Have you altered your UAC settings?

Do you see the Command Prompt as Admin when you right-click the start button?

Share this post


Link to post
Share on other sites
22 minutes ago, John L. Galt said:

OK, dcmargo, if you can reboot, and then check.  If it still breaks, then you'll need to disable those settings again.  I had hoped that Trusteer had also pushed out a new update today.

Nope, after rebooting I'm having the exact same issue. All three aforementioned settings are affecting Chrome and it is still crashing.

Share this post


Link to post
Share on other sites

Chrome   49.0.2623.110 m (which has just started updating!)

MBAE 1.08.1.1189

Meanwhile Rapport won't show other than an icon on the toolbar...watch this space. I think it's sulking whilst awaiting a Chrome relaunch...

 

Share this post


Link to post
Share on other sites

IBM Security Trusteer Rapport fired up after Chrome shut down and claims to be Emerald Build 1609.47

Meanwhile...Chrome is suppressed by MBAE again :o(

Share this post


Link to post
Share on other sites

I've just looked...

  MBAE -> Settings -> Advanced Settings -> OS Bypass Protection -> CALL ROP gadget protection (32/64) -> is unchecked for Chrome...

Still suppressed by MBAE

Another suggestion would be welcome... (please)

Share this post


Link to post
Share on other sites

@Leonard you tried the fix that John posted above

Try the following:   MBAE -> Settings -> Advanced Settings -> OS Bypass Protection -> CALL ROP gadget protection (32/64) -> uncheck for Chrome -> Apply ..

Share this post


Link to post
Share on other sites

   The staff is looking into it,  . I can't advise you any further. They will find a fix. 

    

Share this post


Link to post
Share on other sites
18 minutes ago, dcmargo54 said:

Just installed the Chromium Browser, latest stable build, and it runs fine with default MBAE settings.

I'm sure this is because the Rapport extension doesn't work in Chromium.

Share this post


Link to post
Share on other sites

Lol yeah, you beat me to it on that one.  But, what's more, is that Trusteer Rapport users using Firefox and IE don't have an issue.  It's only the specific combination of Chrome, TP and MBAE.

The MBAE FAQs show that TP has been an issue with MBAE for a while, but that was with an older version. The last build apparently made something go wonky in the way Chrome is protected by MBAE.  I don't have TP installed at all, and I have 0 issue with Chrome and MBAE.

In addition to the fixes that Pedro posted, he also noted that they have already contact Trusteer and that both companies are working on a solution, and I know he will be back to let y'all know when it gets resolved.

Share this post


Link to post
Share on other sites

@Leonard - there is another setting that was mentioned in the big thread that makes it all work.

Please see this post for the information (there is another line, not just that one that you have already done):

 

Share this post


Link to post
Share on other sites

Aha! Thanks. MBAE -> Settings -> Advanced Settings -> Advanced Memory Protection -> Malicious return address detection -> uncheck for Chrome -> Apply

seems to have worked without a reboot too. (Of course switching off a security protection because of a false positive makes me wheeze...)

 

Share this post


Link to post
Share on other sites

@rwmjlally  There was a Google Chrome Update dated today [4/07]  to 49.0.2623.112  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.