Jump to content

[SOLVED] Making a custom activity stream default ... doesn't

Recommended Posts

I'm guessing this is an IPS issue.

On the Activity tab up above, hovering over it allows you to select a stream.  The drop down under Activity Streams allows you to create a stream.  I've managed to set one up that is functionally very similar to the Managed Content tab under IPS 3, but setting it to default ... well, doesn't set it to default.

The settings for that managed content custom stream as as shown in the picture:

MB Forums 5.PNG

I changed the name from test 2 to something else.  I then saved it.  I then opened the stream, and used the green check next to the stream name to set it as default.

Here is what it looks like, including the default check:

MB Forums 6.PNG

However, when I click on the activity tab, the default it shows me is ... All Activity.

Can anyone verify if this is a bug with IPS?

Link to post
Share on other sites

I created a custom one called "Today" and changed only the time to "Specified Number of Days" and set it to 1 day.  I pick that stream each time I go in and often change it to "Content Items Only" once I'm in.  Most of the time it works, but sometimes it also decides that several hours ago is a great place to call now.  If I want to call now now (if you're following), I have to go out and go back in.  Even a shift+reload doesn't fix it, so t think its code silliness and not browser caching.

I keep a rubber chicken handy to slap my screen with, but only when the weirdness reaches a fever pitch.  And no, I haven't had a beer!

Link to post
Share on other sites

I think that the majority of us dealing with these idiosyncrasies should get together for a virtual pub crawl after all this is settled, my friend.  A beer sounds fantastic right about now.

I can't do the rubber chicken thingy though.  I'll break my nice monitors.

I usually go to a tennis court to relieve my frustrations on a yellow fuzz covered sphere at high velocity.  Works well.  Most of the time....

Link to post
Share on other sites

Canaries.  *shudder*  The baby ones are always underfoot.  Try being the operative word....

I am going to keep working on the default stream thing.  I hope it is a setting / bug and not something in my browser of choice....so to rule that out, I'm testing in other browsers as well.

Link to post
Share on other sites

  • Root Admin

Agreed it does not save as the "real" default if you click the Activity alone link. However it does place a quick link on the top right for me so that does work. But as it's not really seeming to keep the "Activity" link as your real default we'll report to IPS as a bug.


I have these two with the 19 being my custom one also set to default but does not replace the main Activity link as the real default.





Thanks John


Link to post
Share on other sites

Wait.  I figured it out.

It makes it default - at the right side of the top of the forums.  In stead of New Activity, what you now see is whatever stream you've made default.  But it may take a couple of page refreshes to show up.

So, it is not a bug.

Link to post
Share on other sites

It is working here.  In the first picture below, you can see that the default stream is to show New Followed Content, whereas I have pulled down Today and it is not the default stream.

MB Forums Default Stream 1.PNG

In this second picture, as soon as I mark Today as the default, a message pops up showing that it is now the default stream.

MB Forums Default Stream 2.PNG

However, I did not notice this behavior before, so it very well may have changed after I started this topic.  Plus, the message says ALSO meaning this is in addition to just marking it as default. 

Link to post
Share on other sites

  • celee changed the title to [SOLVED] Making a custom activity stream default ... doesn't
  • celee locked this topic
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.