Jump to content

[SOLVED] Search Engine Errors (1C205/3)


Recommended Posts

Hi:

In addition to the previously requested RFF to restore "Ascending" and "Descending" to the Sort algorithm...

I'm not sure why there is a "time out" feature on searches?

I can understand having flood control for POSTING, but why for SEARCHING?

Problem: When using the "Members" tab on the main page, attempts to change the "Sort By" selection in the drop-down menu result in errors.

Steps to reproduce:

  1. Click the "Members" tab on the main page
  2. Click the "Sort By" button
  3. Change the selection from the default ("Name") to "Joined" or "Post Count"
  4. EDIT: I might be wrong, but I think the errors appear ONLY when performing the search without being logged in (especially since the error dialog includes a forum sign-in button).

Expected result:

  1. Display would update to reflect the change from "Name" to the new choice

Observed result:

  1. Error code 1C205/3 (see screen shot)
  2. EDIT: I might be wrong, but I think the errors appear ONLY when performing the search without being logged in (especially since the error dialog includes a forum sign-in button).

Is there a functional, architectural or other reason for the delay?

Can it be fixed?

Or this just weird/sloppy coding to tell the user that the sort will take some time and to wait for the results?

 

Thanks, as always,

2016-03-29_5-31-57.png

Link to post
Share on other sites

I'm aware of a lot of forums having limitations on the search feature (cooldowns) because it could be easily abused. However, these are usually removed for Staff members or members with special titles. Maybe it used to be this way but the permissions got reset during the upgrade?

Link to post
Share on other sites

I'm too tired to test it, but I think I only see the error when I am NOT logged in.

Perhaps others can try to replicate the behavior while offline and logged-in, as well.

Nonetheless, it seems unnecessary & inefficient to make the user wait 5-10 seconds after selecting a different sort option from the drop-down menu?

JMNSHO

Link to post
Share on other sites

Well I just tested multiple searches in a few seconds while being logged in, and it worked fine. And if you change an option in the search, you still need to do a new search after, which means a new query. This can be easily abused, hence the cooldowns.

Link to post
Share on other sites

  • Root Admin

Because searches are actually very heavy intensive resource hogs. If  you have multiple users doing them at the same time it can drag down the performance of any site. Even here at day job if users run big searches for reports it can make the program unresponsive. Why we push reporting off to it's own reporting server.

 

Link to post
Share on other sites

Hi:

10 hours ago, Aura said:

Well I just tested multiple searches in a few seconds while being logged in, and it worked fine.

I have not yet had time to re-test & reproduce the error, but as I mentioned in my original post, I think the error only occurs when one is NOT logged in.

In any event, the error is NEW to v4. 

If it is necessary, then so be it. But perhaps the cooldown interval can be reduced a bit?

Thanks,

Link to post
Share on other sites

  • celee changed the title to [SOLVED] Search Engine Errors (1C205/3)
  • celee locked this topic
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.