Jump to content
LimboSlam

(False Positive) Updating or installing Foxit Reader

Recommended Posts

Just as the reads.

 

Oh, an FYI, Pale Moon (an Open Source, Goanna-based web browser forked-off from the Firefox/Mozilla source code, focusing on efficiency and ease of use) doesn't seem to like this forum. I can sign in, search and read threads here, but when it comes to actually posting or creating a new thread, it won't show the field to start typing. Why is that? 

 

Anyways, here are my attachments: 

FoxitUpdater.zip

mbarwind-00.zip

MBAMSERVICE.zip

Ok sorry, there was another attachment which was the setup.exe of Foxit Reader, but it was to large. So I hope this enough.  :) 

Share this post


Link to post
Share on other sites

Im not sure about the open source browser, there could be a number of reasons for the browser issue as it is an open source project.

 

As for FoxiT, thanks for the feedback and logs! this will help and we will look into this asap!

Share this post


Link to post
Share on other sites

Nice! Can't wait until the next update!  :)

 

Ok, so I found the issue and it seems you guys do some strict UA detection, such as looking for the Firefox slice in ones browser. So for you guys, my override is: Mozilla/5.0 (Windows NT 6.1; rv:26.0) Goanna/20160222 Firefox/26.0. Yeah this rendering issue isn't caused by the browser per se, or because the browser (Pale Moon) is unable to render this forum or the specific functions of it, but rather by this forum presenting different Web design code to our browser because of what it thinks it is. But I could be wrong as I took an educated guess knowing this:

Quote

........in this day and age where we've gone from emerging standards back to a million drafts and random implementations of browser-specific code, sites that want to be "modern" (meaning relying on bleeding edge code that may not be supported or even standard) often end up doing this cheap, outdated "browser detection" and choke on the user agent string presented.........

 

So knowing that, our version of Gecko/Goanna (Goanna (an independent implementation derived from Gecko) is the name for the Open Source layout/rendering engine used in the Pale Moon web browser) Now where would I take this up officially so I can ask your developers or team leaders to support Pale Moon properly. To do this, you would just need to look for the Pale Moon slice and the version of Goanna, which is v2.0. No this isn't outdated as we are fork and so rebooting the version number of the engine (found in Pale Moon v26+) to something more manageable and clear than a direct product-tied version of Firefox (Pale Moon isn't affiliated with or subject to either code releases or publication plans of Firefox/Mozilla Corperation), and will be updated as the engine is updated.  

Share this post


Link to post
Share on other sites

Hello LimboSlam:

It is highly unlikely the IP.Board/Malwarebytes forum maintainers will look for your browser observations in this sub-forum.

However, you may wish to consolidate your observations/thoughts and open your own new topic within the Forums Update - FAQ, Issues & Feedback sub-forum.

Thank you.

Share this post


Link to post
Share on other sites

Yes thank you for pointing me to the right direction. I'll do this later today, ok.  :)

 

Keep up the good work! :like:

Edited by LimboSlam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.