Jump to content

Recommended Posts

I wanted to add Virtualbox to web exclusions in order to allow the P2P app from guest OS to work fully, but even if I do this I still get the alerts. Virtualbox creates multiple processes of Virtualbox.exe complete with same path, only arguments are process specific. I think the web protection process exclusion feature was not designed to consider this scenario.

 

Link to post
Share on other sites
  • 4 months later...
  • Root Admin

Actually to bypass that you should be able to change your network connection so that the VM has it's own IP from your router instead of sharing the one from your main computer. I don't use VirtualBox but I do use VMware and nothing that happens on my guests on VMware are controlled by my main computer.

Doing it the way you're currently trying to you'd have to ensure that all processes are excluded. It's unlikely that only 1 process is involved in running VirtualBox.

Let us know how it goes.

Thanks

 

Link to post
Share on other sites
  • 6 months later...

This has been fixed in MBAM 3.0.

VMware was never affected because it has unique named processes. The NAT networking process is called vmnat.exe.

Virtualbox on the other hand it creates multiple processes named Virtualbox.exe and one named VBoxSVC.exe all starting from Virtualbox installation folder. One of the Virtualbox.exe processes handle networking.

Edited by pal1000
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.