Jump to content

Clicked On An EXE With A Folder Icon By Mistake

Recommended Posts

Windows 7 Ultimate x64


Long story short, accidently clicked on what appeared to be a Folder, ended up being an EXE with a standard Windows folder icon for its display icon, and conveniently, the file name was longer than Windows Explorer “Name” column opens up as default, so I didn’t see that the file ended in EXE.


Clicked it, and absolutely nothing happened.


THAT was the first sign it was too late, and then I realized what had happened.


Before rebooting, I immediately began an onslaught of AV scans, Rootkit scans, went through the Registry to clean out all of the Run/RunOnce entries, checked Startup in MSCONFIG just to make sure nothing was added that would start on reboot, etc.


Rebooted into Safe Mode, and did a “FULL” Malwarebytes scan.


Malwarebytes found a few, “iffy” things, but only one item that it called true Malware, and that item was simply entitled, “Backdoor.Agent”.


So, none the less, I had Malwarebytes remove everything.


Rebooted normally back into Windows 7, and everything seemed just fine. No, “noticeable” abnormalities.


Until I went on a hunt, doing normal everyday activities in an attempt to see if I could find any damage.


What damage was found, is more of an immense annoyance, than substantial damage.


  1. No program will remain the default program. Every time I start Firefox, for example, it asks if Firefox should be my default browser. I check yes, and remember, shut down Firefox, and then restart Firefox, and it asks me all over again.

It even stopped Malwarebytes from starting with Windows, even if I had, “Start With Windows” checked. And if I    would start Malwarebytes manually, there was no “real time protection”. It would let me, “tick” the real time protection on, but on reboot, Malwarebytes would not start with Windows, nor was the protection on again. Another issue most likely dealing with the Registry. I have since uninstalled, and reinstalled Malwarebytes, and it is working normally again, but still not picking up on whatever is doing this.


2. Any program I install that installs an entry into the Context “Right-Click” Menu, that entry now does not get entered into the Context Menu.


3. File extension associations are gone, and “will not stick” either. For example, I used to be able to click on any video file, and Microsoft Windows Media Player would bring up the video. Now, anytime I click on any video, Windows opens the video with QuickTime, even if I tell it to use Media Player as the default video player. So I go into Set Association in Windows, set the extensions back to where they belong. It says it took it correctly. Try to open a video file again, and poof, it opens it with QuickTime again.


Some associations are still fine, for example, if I click on a text file, Windows opens the text file using Notepad, as it should, by default.


4. All Restore points were also removed, …it knew to do that also.


Bottom line issue, while trying to get rid of this annoyance, by trying a number of different procedures, I actually did, but I did so many things at once, that I am not sure what fixed it, AND, it was only fixed for three days, and now its back, all over again, even with Malwarebytes running full strength 24/7 on my PC. But when I had it fixed, everything worked perfectly again for those three days.


So, I think it’s safe to say that whatever this is, it lays dormant, to come back again, and as I said, it’s more annoyance, than anything, because the rest of Windows is humming along just fine.


Can anyone help me, please?

Link to post
Share on other sites



I have noticed that I was supposed to have attached the findings of a Farbar Recovery Scan. My appologies.


I will attach them in this posting.


Another note to mention in my Update:


After running the Farbar scan, I see, "mrt.exe" located in my System32 folder. I would think, not good.


Also, "SFC /SCANNOW" keeps giving me this error message:


"Windows Resource Protection could not perform the requested operation."


I have even dropped to Safe Mode and ran "SFC /SCANNOW". SFC makes it to 100%, but then still gives me that error message.

I understand about DISM, but that is for Windows 8 and above, I have Windows 7.


I have also ran numerous CheckDisk's on my boot drive, by rebooting into a check, as well as checking my bootdisk from another bootable drive in my system. No errors are found either way.




Link to post
Share on other sites

  • 6 months later...
  • Root Admin

We're sorry. It looks like your topic was somehow overlooked. Due to the length of time we'll go ahead and close this topic now but if you still actually need help please send a private message to one of the Moderators and we'll assist you.Thank you and sorry we missed your topic.

Link to post
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.