Jump to content

0xc0000279 Start Error

Recommended Posts

So this started about 2 days ago.  I noticed that my Malwarebytes was not starting automatically upon startup of my OS.  I am on Windows 10 by the way.  So I traveled into the Program Files (x86) and attempted to run mbam as an Administrator.  It gave me the 'The application was unable to start correctly (0xc0000279).  Click OK to close the application.'.  I have attempted to circumvent this by running rkill and seeing if I could run it, still didn't work.


I should also state, I'm not one to torrent/visit harmful websites.  This really did come out of the blue and I'm wondering if it's just something with Malwarebytes and Windows 10.


Regardless, I also have ESET on my computer, which is running and updating fine.  I have paid versions of both ESET and Malwarebytes so they both have real-time protection as well.  I decided to go into Safemode and see if I could launch MBAM, which I could.  I ran a scan and it ended up finding 2 Trojans and 2 'Security (somethings)'.  I obviously removed them and moved on.  ESET also ran and found nothing.  I have also gone and ran Malwarebytes-Clean and reinstalled Malwarebytes afterwards.  I am still getting the error when trying to start this though.


I have looked through my registry and used Process Explorer (along with Task Manager) and have not found anything strange.


If anyone can help me it would be greatly appreciated.  I don't know where this is coming from but it's obnoxious and any help would be greatly appreciated.  My OS really is running absolutely fine, it is just Malwarebytes refusing to start.


Hope to hear from someone soon!

Link to post
Share on other sites

So, an update on this.


After trying to counter this problem from a few different angles, I decided to look through more posts on the forums than I already did.  I ended up coming upon some more posts about people having this same error with Windows 10 and being directed to turn off the 'Real-Time Protection' module and such as the Moderators and such already knew there is something wrong with Win10 and that module.


I decided to give it a shot.


I booted back into safemode, ran MBAM, and as per usual it started up.  I disabled the module and ran another scan for the heck of it.  Nothing came up as infected, etc.  So then I turned Safemode off through Msconfig and restarted.  I loaded up my OS normally and moved to ProgramFiles(x86) and double clicked on MBAM.


It loaded up.


I am a very thorough person with how I trouble-shoot things and I am more than happy to help the moderators with any log files that you guys would need in order to help trouble-shoot this.  Maybe it is something that has arisen because of the most recent batch of Windows 10 updates or something.  From what I can tell though, it is the Real-Time Protection module that was stopping MBAM from loading.


Looking forward to hearing from you guys so we can knock this out.

Link to post
Share on other sites

I am at a loss..So I decided to go in and disable all of the modules and slowly load them back up, one-by-one.  Inbetween each module I check off I went ahead and did a restart.  I do not know what fixed this.  Maybe it was the update MBAM did when it was in safe-mode with networking?  If any other problems arise I will be certain to come back and let you guys know.  I really do not know what happened..it is strange to say the least.


Below are the screenshots I took of each part before I did a restart.  I started off by labeling them 'Test1', 'Test2', etc. and if they worked, I changed the screenshot name to 'Works1', 'Works2', etc.  As you can see, they all worked.  MBAM started correctly at Windows startup and everything.  I even just shut MBAM down and moved myself into the ProgramFiles(x86) and started it from there.  Loaded up fine.


I really am at a loss for words and I am sorry for any confusion that may have been caused by this.  Something changed and it's all working now.


Thank you for your time.





Link to post
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.