Jump to content

MBAE 1.08 Beta Preview


Recommended Posts

It could be, but the problems I had previously were: MBAE was running, and preventing web-browsers from starting. It seems strange that I am now having a totally different kind of problem.

 

I'll dig a little deeper tomorrow or subsequent days. Thanks for your assistance.

Link to post
Share on other sites
  • Replies 388
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

04-11-2015

-    Disabled WinPatrol from Startup Items. Rebooted.
-------------------------
-    Briefly saw "Malwarebytes Ant-Exploit 64bit tasks"  and "Malwarebytes Anti-Exploit Service" in Task Manager, but these disappeared after popup messages regarding scripts from Piriform and one other (I failed to read it properly while taking notes). Remaining in Task Manager is "Malwarebytes Anti-Exploit (32bit)"
SCREENSHOTS AVAILABLE
-    Popup message has appeared: "Malwarebytes Anti-Exploit Protection is not started. The Anti-Exploit process will be terminated."
-    Firefox starts and quits unhindered. No MBAE balloon message.
-    Rebooting.
---------------------------
-     Briefly saw "Malwarebytes Ant-Exploit 64bit tasks"  and "Malwarebytes Anti-Exploit Service" in Task Manager, but these disappeared. Remaining in Task Manager is "Malwarebytes Anti-Exploit (32bit)"
-    After considerable delay (I had a meal and came back), popup message has appeared: "Malwarebytes Anti-Exploit Protection is not started. The Anti-Exploit process will be terminated."
-    Firefox starts and quits unhindered. No MBAE balloon message.
-    Switched off (within the application) Comodo Internet Security features: Antivirus, Firewall, Auto-sandbox, Viruscope.
-    Reooting.
----------------------------
-    Briefly saw "Malwarebytes Ant-Exploit 64bit tasks"  and "Malwarebytes Anti-Exploit Service" in Task Manager, but these disappeared. Remaining in Task Manager is "Malwarebytes Anti-Exploit (32bit)"
-    Firefox starts and quits unhindered. No MBAE balloon message.
-    Uninstalled MBAE 1044 using control panel.
-    Rebooting
-----------------------------
-    No mention of MBAE in Task Manager.
-    Re-installed MBAE 1044.
-    Tried starting Firefox. Got MBAE ballon message. Firefox failed to start.
-    Tried starting PaleMoon. Got MBAE ballon message. PaleMoon failed to start.
-    Tried starting IceDragon. Got MBAE ballon message. IceDragon failed to start.
-    Tried starting Internet Explorer. Got MBAE ballon message. IE started partially. One blank tab open, but browser is unusable, doesn't respond to controls.
-    In Task manager, all 3 items appear together: "Malwarebytes Ant-Exploit 64bit tasks"  and "Malwarebytes Anti-Exploit Service" and "Malwarebytes Anti-Exploit (32bit)"
-    Rebooting
------------------------------
-    In Task manager, all 3 items appear together: "Malwarebytes Ant-Exploit 64bit tasks"  and "Malwarebytes Anti-Exploit Service" and "Malwarebytes Anti-Exploit (32bit)"
-    Tried starting Firefox. Got MBAE ballon message. Firefox failed to start.
-    Tried starting PaleMoon. Got MBAE ballon message. PaleMoon started and quit successfully!
-    Tried again starting Firefox. Got no MBAE ballon message. Firefox started and quit successfully.
-    Tried starting IceDragon. Got MBAE ballon message. IceDragon failed to start. I noticed "IceDragon (32 bit)" in Task Manager.
-    Tried again to start IceDrago. Noticed 2 instances of "IceDragon (32 bit)"  in Task Manager. Ended those 2 processes in Task Manager, and also ended "Firefox (32 bit)" which I noticed still running. Perhaps Firefox hadn't quit so successfully after all.
-    -    Tried starting IceDragon. Got MBAE ballon message. IceDragon failed to start. Ended  "IceDragon (32 bit)" in Task Manager.
-    Tried starting Firefox. Got MBAE ballon message. Firefox failed to start. Ended "Firefox (32 bit)" in Task Manager.
-    Tried starting PaleMoon. Got MBAE ballon message. PaleMoon failed to start. Noticed "Pale Moon web browser (32 bit)" in Task Manager. Ended that task.
-    Tried again starting PaleMoon. Got MBAE ballon message. PaleMoon failed to start. Ended "Pale Moon web browser (32 bit)" in Task Manager.
-    Tried starting Internet Explorer. Got MBAE ballon message. IE started partially, didn't respond, then crashed.
-    Tried starting Firefox. Got MBAE ballon message. Firefox failed to start. Ended "Firefox (32 bit)" task in Task Manager.
-    Tried again starting PaleMoon. Got MBAE ballon message. PaleMoon failed to start. Ended "Pale Moon web browser (32 bit)" in Task Manager.
-    Rebooting.
-----------------------------
-    In Task manager, all 3 items appear together: "Malwarebytes Ant-Exploit 64bit tasks"  and "Malwarebytes Anti-Exploit Service" and "Malwarebytes Anti-Exploit (32bit)"
-    Tried starting PaleMoon. Got MBAE ballon message. PaleMoon failed to start. Ended "Pale Moon web browser (32 bit)" in Task Manager.
-    Ran mbae-support.exe    (from User account, not Admin)
ZIPPED FOLDER AVAILABLE
-    Un-installed MBAE by Control Panel.
-    Firefox starts and quits successfully. NO remnant Firefox task in Task manager.
-    PaleMoon starts and quits successfully. NO remnant in Task Manager.
-    IceDragon starts and quits successfully. NO remnant in Task Manager.
-    Re-activating features in Comodo Internet Security Premium.
-    rebooting
----------------------------

It seems to me that I had a faulty installation of MBAE, and thus had no protection but was able to use my browsers. After re-installing I had MBAE running but was back to the old problem of being unable to use my browsers.

 

Is it odd that Task Manager reports both 32-bit and 64-bit tasks from MBAE running together?




 

Link to post
Share on other sites

MBAE 1.08 is now final and has been released to new downloads from the malwarebytes.org website (build 1044).

 

@Pijuvwy we'll continue investigating the issue you encountered offline and provide a fix as soon as possible.

Link to post
Share on other sites

05-11-2015

-    Used CCleaner (run as admin) to disable Startup of Comodo. Also disabled Startup of WebPatrol and MBAE, even though those are currently uninstalled or already disabled.
-    Reboot.
------------------------
-     Comodo is still running.
-    It seems to be designed as hard to kill. Downloading Startup Control Panel from https://web.archive.org/web/20131106030702/http://www.mlin.net/StartupCPL.shtml
-    Had to run the installer as Admin, due to problems as User.
-    That didn't seem useful. It didn't even list Comodo.
-    Comodo IS installer does not include Uninstall feature. Using Control Panel to uninstall.
-    Rebooting to compete Uninstall.
-----------------------------
-    No sign of Comodo IS in Task Manager. Also no sign of WebPatrol or MBAE.
-    Installing MBAE 1044
-    In Task manager, all 3 MBAE items appear: "Malwarebytes Ant-Exploit 64bit tasks"  and "Malwarebytes Anti-Exploit Service" and "Malwarebytes Anti-Exploit (32bit)"
-    Firefox starts successfully, with MBAE balloon message. Quits successfully, leaving no remnant in Task Manager.
-    PaleMoon starts successfully, with MBAE balloon message. Quits successfully, leaving no remnant in Task Manager.
-    IceDragon starts successfully, with MBAE balloon message. Quits successfully, leaving no remnant in Task Manager.
-    Internet Explorer starts successfully, with MBAE balloon message. Quits successfully, leaving no remnant in Task Manager.
-    Rebooting.
--------------------------------
-    In Task manager, only 2 MBAE items appear: "Malwarebytes Ant-Exploit 64bit tasks"  and "Malwarebytes Anti-Exploit Service".

"Malwarebytes Anti-Exploit (32bit)" is missing.

-     Firefox starts successfully, with NO MBAE balloon message. Quits successfully, leaving no remnant in Task Manager.
-    Same for PaleMoon and IceDragon. Same for Internet Explorer.

-    rebooting
------------------------------
-    In Task manager, only 2 MBAE items appear: "Malwarebytes Ant-Exploit 64bit tasks"  and "Malwarebytes Anti-Exploit Service".

"Malwarebytes Anti-Exploit (32bit)" is missing.

I also noticed that MBAM is missing. It has been present in some of my screenshots and absent in others.

-    Firefox starts successfully, with NO MBAE balloon message. Quits successfully, leaving no remnant in Task Manager. Same for PaleMoon and IceDragon. Same for Internet Explorer.
-    Uninstalling MBAE via Control Panel.
-    rebooting
-------------------------------
-    Re-installing Comodo IS.

I'd say your problems go further than incompatibility with Comodo Internet Security.
 

Link to post
Share on other sites

Thanks for the details Pijuvwy. This confirms our investigation that this is a new bug in the Comodo hooking mechanism. I've updated the Known Conflicts list to reflect it.

 

As for the MBAE UI (mbae.exe) not starting after your first reboot, this must be due to some other application removing the MBAE startup entry. Can you check in your registry to see if there's a startup entry for MBAE in HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run?

Link to post
Share on other sites

Sorry Pedro, I've since being doing some cleanups with Autoruns.exe which would probably have destroyed what you're looking for. I could install MBAE again and repeat the situation, but I would need some instructions on how to check for the registry item, as I laack experience.

 

Actually, I have re-installed the 1044 release aand re-tested it (looking for any difference based on changed digital signing). So if you give me some pointers I could check for the registry entry.

Link to post
Share on other sites

FYI there has been a Comodo update to fix an issue with Chrome. I think they were referring to Google Chrome, but I thought it might make a difference for Firefox. It hasn't helped with the MBAE issue aparently.

Link to post
Share on other sites

You can actually check with autoruns if you are not familiar with the registry.

 

Do this:

 

1- Uninstall Comodo and reboot

2- Install MBAE and reboot --- are all 3 MBAE processes running?

3- If only 2 MBAE processes are running, check if in Autoruns there's a startup entry for MBAE.

Link to post
Share on other sites

Do you have an MBAE icon in the system tray?

 

Which processes are you seeing in TaskManager?

The 3 processes that should be running are:

mbae-svc.exe

mbae64.exe

mbae.exe

 

You might need to choose "Show all processes" in TaskManager to see them all.

Link to post
Share on other sites

I've never noticed the MBAE icon in the system tray. Also, though, I've never expended the system tray to look for it. It's not there presently.

 

mbae64.exe & mbae-svc.exe are present, shown as "Malwarebytes Ant-Exploit 64bit tasks"  and "Malwarebytes Anti-Exploit Service" in the Windows 8 Task Manager.

 

I ran Task Manager as Admin and "enabled" the MBAE startup process. I'll see if that makes any difference.

Link to post
Share on other sites

I ran Task Manager as Admin and "enabled" the MBAE startup process. I'll see if that makes any difference.

Was it disabled???

 

If it was disabled, that's the reason why it's not showing after a reboot.

Link to post
Share on other sites

It's enabled now, and now all 3 tasks are showing. mbae.exe is back on-board.

 

Yes, I would have disabled it earlier while MBAE was uninstalled. I was getting rid of unused or redundant entries, using Autoruns etc.

 

MBAE seems to be working now, with Comodo uninstalled, so that simplifies things to a single problem. That's a bit of a relief :)

 

3 Firefox-based browsers are working and protected by MBAE, as is Internet Explorer.

 

MBAE is present in system tray.

 

That's looking better. Need to confirm with another restart.

Link to post
Share on other sites

On my other machine with Windows 10 x64 installed ballon messages stopped showing after a few days. When checking logs They show MBAE is working and protecting everything I included in shields. Going back to default settings doesn't solve the issue

 

Any advise?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.


Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.