Jump to content

Premium Version: High CPU/RAM Usage + No Taskbar Icon + Not Updating

Recommended Posts



First time posting.  Have been using both the free and Premium versions of Malwarebytes Anti-Malware for years.  Recommend it to everyone I know.  Very happy with it until the latest version of the Premium software,


Now I'm experiencing 3 problems:


1] High CPU/RAM usage showing @ Task Manager

2] Taskbar icon no longer loads/shows up

3] Does not auto-update anymore, says it cannot reach the server/etc.

The high CPU/RAM usage dramatically effects my system and happens soon after the system is either brought out of sleep mode or has just been started.  The only way I can remedy it is to log into the administrative account on my system and kill it there using Task Manager.  Cannot shut it down manually @ my account, has to be in the admin account.


Before this latest update, had no issues whatsoever.  Now it has become unusable as is.  I have tried several times to uninstall/reinstall, cleaning all remnants in the process; have done it in my account and the admin account, all without any luck.


Please see the following 2 screenshots showing what takes place using Task Manager.


Once the trouble starts, 90-100% of the CPU is used without anything else running [software, browsers, etc.]:




It's the top CPU cycle user; anywhere from 5-15 instances of it might be running @ once:




Need help.  Thanks in advance.

Link to post
Share on other sites

Forgot to mention:


1] There use to be a password option for the settings; that's gone now, too.


2] If it helps, my system info:


Win 7 Ultimate 64-bit SP1

Intel Quad Core Q6600




EVGA GeForce GTX 560 Ti 1280MB GPU

CM Real Power Pro 1000W PSU

CM Stacker 830 SE Case


Please let me know if there's anything else, like logs/etc., I can post.  Cheers.

Link to post
Share on other sites

Hello and Welcome to Malwarebytes :)

You should not have that many mbam.exe *32 files running at one time.

Let's try this first....

Thank You,


Link to post
Share on other sites

The main is problem solved! :D


Firefox: Thanks for your help; following step 1 of your instructions seems to have done the trick.  Just about everything's back to normal.  Only thing not fixed is the password for the settings.  That's still gone/not there anymore.


Happy that I can use my system, though. Cheers.

Link to post
Share on other sites

I spoke too soon.


While the issues of high CPU/RAM usage and the icon missing from the taskbar have been fixed, the software still is not able to auto-update itself.  Gives the same message of it not being able to reach the servers/etc.


I have MWB AMW Premium on 2 systems: my main workstation, which is having the problem, and my laptop, which is fine.  There, the password protection for the settings is still there and looks like this:




On my problem workstation, when I click on "Settings", I don't get this pop-up.


I set up password protection on both systems when this software was 1st installed.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.