Jump to content

Windows 10 takes extremely long time to hibernate/hybrid sleep


iamauser

Recommended Posts

In Windows 10 when I want to enter hibernate or hybrid sleep the screen turns off very fast but it takes 2-3 minutes for the PC to turn off.

 

Already clean installed W10, but it still takes long time to do this, this also apply to shutdown when I have fast startup enabled. If I turn off fast startup or enter sleep(not hybrid) no issue. I think it should be the issue of hibernate but turn off and turn on hibernate again will not fix this issue.

 

All drivers are up to date and hibernate works well in Windows 7 and 8.

 

If I reboot my PC and the first time enter hibernate is fast, after that it will be slow.

Link to post
Share on other sites

When the PC get's the hibernate/hybrid sleep command, it has to make a snapshot of what's in RAM first, then give all running processes the command "OK we're going to take a break now", then it has to wait until all processes report back, before it can write to the disk. This of course takes longer than sleep, which doesn't have the "write to disk" part, and slower than a WinX shut down, that just closes the processes, and turns the PC off. Added to that if, you're using a Microsoft account, there are a lot more things to stop, and write because of the Universal apps running and live tiles updating.

 

Are you using a HDD or SSD? If you're using a spinner instead of an SSD, it will take even longer, especially if it is a laptop(generally they have only 5400 rpm disks) :) .

 

And as a side note, I have found my laptop takes longer to hybrid sleep/ hibernate than my desktop, and both have Samsung Pro SSD's. I just don't wait for the shutdown or hibernate to complete, before I leave the PC.

Link to post
Share on other sites

Try refreshing your hiberfil.sys file::

Open Command Prompt (Admin)

and give:

powercfg -h off

 

then reboot and give:

powercfg -h on

reboot again

 

Also give:

powercfg -a

 

to get a list of your sleep state options. the output should look similar to mine:

Microsoft Windows [Version 10.0.10240](c) 2015 Microsoft Corporation. All rights reserved.C:\Windows\system32>powercfg -aThe following sleep states are available on this system:    Standby (S3)    Hibernate    Hybrid Sleep    Fast StartupThe following sleep states are not available on this system:    Standby (S1)        The system firmware does not support this standby state.    Standby (S2)        The system firmware does not support this standby state.    Standby (S0 Low Power Idle)        The system firmware does not support this standby state.C:\Windows\system32>

 

Link to post
Share on other sites

In post #5 you said:

In Windows 7 and 8, the process only takes 10-15 seconds, but in 10 it takes 2-3 minutes, there should have some problems when hibernate.

 

 

Were all three OS's on the same PC?

Also if this is the upgrade, you could try and see if a repair install(in place upgrade)  will correct the problem. This way only Windows files will be fixed/corrected, and your files and installed software will remain intact. If you need help, let me know.

 

Important is, after a repair install on Windows 10, you need to check your time zone in date & time in the control panel and resync internet time, also you'll need to re-setup your location settings in the settings app(they will be turned off by default).

 

 

If that doesn't work, maybe clean install will help. It could be a lot of cruft(old unused registry entries, settings, .ini files) causing problems.  

Link to post
Share on other sites

Sorry; I didn't notice the word "clean" in the 1st post.

 

No, just my laptop is a tad bit slower going into hybrid shutdown then my desktop(which has more RAM to save to hiberfile). But both have Samsung Pro 256GB SSD's for the boot drive. With the SSD's I think they boot faster, actually, from a full(WinX) shutdown, which also shut's down a tad faster. But I haven't ever seen 2-3 minute shut down personally, but in another forum I'm in, it has been reported by a couple of other members, but no single definite solution has been found or posted. It seems there are different reasons for the slow hibernate. :wacko: .

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.