Jump to content

Help: I renamed classpnp.sys to classpnp.old, and blue screen

Recommended Posts

Hi All:

  Please help!

It starts that all of a sudden I could not start windows 7 safe mode. And it will hang on at classpnp.sys file. I can intermittently start in normal mode though. So I look up in the website and some guys suggested to rename the system file classpnp.sys into classpnp.old. So I went some trouble to change file ownership and change permission and then change the file name in c:\windows\system32\drivers\classpnp.sys into classpnp.old. After that I am screwed. When I tried to start windows 7 in safe mode or normal mode, I got blue green. This happened immediately after I change the file name so this must be the reason. Now I just want to change the name back to classpnp.sys. Obviously it is difficult for me to do since I tried each item after press F8, and most gives me blue screen. The only one is log into command line mode , but that one shows volumn label as X and did not have classpnp.old but classpnp.sys, so it is not the real system file in C:.

  Anyway, is there a decent way to change the system file name back?

  Thank you again for your help. It is urgent since I have to use my laptop heavily.



Link to post
Share on other sites

Did you make a backup/system restore point before you made this change?

Even if you didn't, there may be a System Restore point available that you can use.


If so, use a Startup Repair disk to access System Restore and restore the system to a point before you made the change.

If there are no System Restore points, then try opening up a Command Prompt Ifrom the Startup Repair disk) and renaming classpnp.old to classpnp.sys (it should be located in C:\Windows\System32\drivers folder).

Link to post
Share on other sites

I did make a restore point but when I choose restore point it says I did not designate a operation system so would not do the restore.

Thank you for the reply. But for command prompt, when I dir the files in system32\drivers, it shows the classpnp.sys (instead of .old), and its disk label is shown as X instead of C. So it is not really the actual C volumn and the change name there won't help.



Link to post
Share on other sites

Can you run SFC.EXE /SCANNOW from an elevated (Run as adiminstrator) Command Prompt?

Does that help?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.