Jump to content

Not sure if I'm infected. Can't boot because of 'critical boot file corrupted'

Recommended Posts



I noticed that our family laptop was in "Startup Repair" mode this morning (it seemed fine about 8 hours prior when I used it; not sure if anyone else used it after).  The details indicate a corrupted "d:\windows\system32\drivers\spldr.sys" file.  The attempted repair fails, and I'm unable to boot into windows.  I can run a command prompt from the "Startup Repair" console, and ran a "chkdsk d: /f" which claimed there were no issues.  I'm not sure if this issue is the result of a virus and I'm not sure how to proceed since I don't know how to get the required tools onto this machine.


Thanks for any help you can provide...



Link to post
Share on other sites




They call me TwinHeadedEagle around here, and I'll try to help your with your issue.




Before we start please read and note the following:

  • We're primarily oriented on malware removal here, so you must know that some issues just cannot be solved and you must be prepared for this. Some tools we use here will remove your browser search history, so backup your important links and all the files whose loss is unacceptable.
  • Limit your internet access to posting here, some infections just wait to steal typed-in passwords.
  • Please be patient. I know it is frustrating when your PC isn't working properly, but malware removal takes time. Keep in mind that private life gets in the way too. Note that we may live in totally different time zones, what may cause some delays between answers.
  • Don't run any scripts or tools on your own, unsupervised usage may cause more harm than good.
  • Do not paste the logs in your posts, attachments make my work easier. There is a More reply options button, that gives you Upload Files option below which you can use to attach your reports. Always attach reports from all tools.
  • Always execute my instructions in given order. If for some reason you cannot completely follow one instruction, inform me about that.
  • I volunteer to help you, so please, do not ask for help for your company/business PC. Companies are making revenue via computers, so it is good thing to pay someone to repair it.
  • If I don't hear from you within 3 days from this initial or any subsequent post, then this thread will be closed.
:excl: I can't foresee everything, so if anything not covered in my instructions happens, please stop and inform me!

:excl: There are no silly questions. Never be afraid to ask if in doubt!




  warning.gif Rules and policies


We won't support any piracy.

That being told, if any evidence of illegal OS, software, cracks/keygens or any other will be revealed, any further assistance will be suspended. If you are aware that there is this kind of stuff on your machine, remove it before proceeding!

The same applies to any use of P2P software: uTorrent, BitTorrent, Vuze, Kazaa, Ares... We don't provide any help for P2P, except for their removal. All P2P software has to be uninstalled or at least fully disabled before proceeding!


Failure to follow these guidelines will result with closing your topic and withdrawning any assistance.



Please download Farbar Recovery Scan Tool x64 and save it to a flash drive.

  • Plug the flashdrive into the infected PC.
  • Restart your computer and tap F8 to bring up the Advanced Menu, then click Repair your computer
  • Follow the prompt to enter keyboard input method, and then the prompt to enter a password. If the machine does not have a password, simply click Enter.
  • In the Choose Recovery Tool menu select Command Prompt.
  • You will see a big black window with a blinking cursor (command prompt).

    notepad.png Access the notepad and identify your USB drive

    In the Command Prompt please type in:

    and press Enter.
  • When the notepad opens, go to File menu.
  • Select Open.
  • Go to Computer and search there for your USB drive letter.
  • Note down the letter and close the notepad.

    FRST.gif Scan with Farbar Recovery Scan Tool

    Once back in the command prompt window, please do the following:

  • Type in e:\frst64.exe and press Enter.

    You need to replace e with the letter of your USB drive taken from notepad!

  • FRST will start to run. Give him a minute or so to load itself.
  • Click Yes to Disclaimer.
  • In the main console, please click Scan and wait.
  • When finished it will produce a logfile named FRST.txt in the root of your pendrive and display it. Close that logfile.

    Transfer it to your clean machine and include it in your next reply.

Link to post
Share on other sites

You have a lot of restore points. Can you try restoring your system to the time before this happened:

Restore point made on: 2015-08-12 02:00:36

Restore point made on: 2015-08-12 09:50:09

Restore point made on: 2015-08-12 10:00:07

Restore point made on: 2015-08-12 11:49:06

Restore point made on: 2015-08-12 12:45:53

Restore point made on: 2015-08-15 15:10:37

Restore point made on: 2015-08-19 01:17:30

Restore point made on: 2015-08-19 02:00:15

You can do it from recovery options.

Link to post
Share on other sites

The 2 most recent restore points (on 2015-08-19) failed (unable to restore a windows journal file - restore point was either damaged or deleted during the restore).  Since it's not clear if these occurred before the issue, I also tried to restore to the restore point made on 2015-08-15 when the machine appeared to functioning properly.  This restore point also failed (unable to restore skype.exe - restore point was either damaged or deleted during the restore).  I didn't try any other restore points after that... I'm not confident that the results will be any different; if you think that is incorrect, I will try a restore point from 2015-08-12.





Link to post
Share on other sites

So the upgrade was a failure, since it requires that the machine be able to boot into windows to handle the licensing correctly.  I'm guessing that since you had me attempt to restore from a previous configuration that you don't see any signs of a virus or malware on the machine that's causing the issue, and that my windows installation must have somehow got trashed?  If this is the case, I'm guessing that I'll need to make a clean install of Windows?



Link to post
Share on other sites

  • Root Admin

Glad we could help. :)

If you need this topic reopened, please send a Private Message to any one of the moderating team members. Please include a link to this thread with your request. This applies only to the originator of this thread.

Other members who need assistance please start your own topic in a new thread. Thanks!

Link to post
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.