Jump to content
meatkakes

[SOLVED] ASUS conflict generating IE/FF Anti-HeapSpraying & Chrome flicker

Recommended Posts

Thanks to @SoCalSienna here I think this is the same problem he has found here.

 

It is some crappy ASUS software component (again!). It has happened in the past as ASUS has a thing for creating crappy software.

 

To fix this:

 

1- Change the ASUS Service to Disabled -> "ASUS Com Service" -> C:\Program Files (x86)\ASUS\AXSP\1.00.19\atkexComSvc.exe
2- Reboot

 

Problem should be fixed. Please confirm.

Share this post


Link to post
Share on other sites

I think this is due to a crappy ASUS software component which is creating problems for other users.

 

Try the following:

 

Click Start -> Run -> type "services.msc" -> Enter -> find "ASUS Com Service" -> double-click and change to Disabled -> OK -> Reboot

 

This should fix the problem.

 

Please confirm.

Share this post


Link to post
Share on other sites

I have a similar problem. Link to files:

 

EDIT: got files, removed link. You can safely attach ZIP/RAR here without linking to external sites.

Share this post


Link to post
Share on other sites

Thanks for the logs nightrain.

 

If you kill the following process and try again, does the problem persist?

 

C:\ProgramData\DatacardService\HWDeviceService64.exe

Share this post


Link to post
Share on other sites

Thanks for confirming nightrain. Can you please send me the file in question?

Share this post


Link to post
Share on other sites

This issue is still unresolved for me. The only process in the list of possible conflicts I had running was: (CMedia) C:\Program Files\ASUS Xonar Essence STX Audio\Customapp\AsusAudioCenter.exe

Killing that process and then attempting to run Firefox/Tor still generates the exploit blocked pop up.

Stopping protection, then opening the browser, then closing, then starting again seemed to temporarily work. I'm not sure if that's what those steps actually suggested to do, they were vague.

But as soon as I sign out, sign back in, attempt to open either browsers, the exploit blocked alert comes right back.

Again, this does not seem to be impacting any of the 64 bit versions of Firefox.

Share this post


Link to post
Share on other sites

Hi @ITC23, it's not "C:\Program Files\ASUS Xonar Essence STX Audio\Customapp\AsusAudioCenter.exe" the one you have to kill.

 

Kill "C:\Program Files (x86)\ASUS\AXSP\1.00.19\atkexComSvc.exe" instead and try again.

Share this post


Link to post
Share on other sites

 

Hi @ITC23, it's not "C:\Program Files\ASUS Xonar Essence STX Audio\Customapp\AsusAudioCenter.exe" the one you have to kill.

 

Kill "C:\Program Files (x86)\ASUS\AXSP\1.00.19\atkexComSvc.exe" instead and try again.

 

I dont have that on my system. The only Asus software/hardware I have is the soundcard.

I do appreciate the time you've spent on this issue.

Share this post


Link to post
Share on other sites

@ITC321, please post your FRST logs.

 

Instructions can be found in the "readme first" link in my signature.

Share this post


Link to post
Share on other sites

I have just been trying to use Firefox and MBAE tells me it has blocked it:-

 

Protection Layer: Application Hardening

Protection Technique: Exploit blocked by Anti-HeapSpray Enforcement

File/Process Blocked: N/A

Attacking URL: N/A

 

Someone please help. I don't want to use IE!!

 

BTW, I'm not sure what's going on with the Forum login but I couldn't get logged in and had to set up a new account. Not impressing me today, people.

 

Share this post


Link to post
Share on other sites

Hi robinking, welcome to the forum and thanks for posting.

 

We currently have a known conflict with an ASUS component that is likely the source of this problem.

 

Please check if you have the following process running in your computer and, if you do, kill it and then try opening Firefox:

C:\Program Files (x86)\ASUS\AXSP\1.00.19\atkexComSvc.exe

 

We are fixing this in the upcoming 1.08 version that will be released to beta soon. But in the meantime if the above fixes your issue simply disable this ASUS service from starting up at boot.

 

PS: moving this to the Product Support sub-forum and merging with the existing thread on the subject.

Share this post


Link to post
Share on other sites

Hi pbust,

 

I'm not on an ASUS, I'm on a Lenovo, unfortunately. Searched for the exe file, anyway, but nothing came up. I'm not sure what to do. I have uninstalled MBAE,rebooted, re-installed MBAE and rebooted and no luck.

 

Only thinkg I can do is turn off MBAE protection ... which defeats the whole purpose ...

 

R

Share this post


Link to post
Share on other sites

Can you please attach your FRST logs?

Instructions on how to run it can be found in the "readme first" link in my signature.

After downloading FRST right-click on it and choose "run as admin".

Share this post


Link to post
Share on other sites

....

Firefox now opens fine, and MBAE does not block it.  The culprit was atkexComSvc.exe. :angry:   Feel free to mark this solved.
....

 

Hi - I'm sorry to report that I was mistaken that disabling the startup autorun of atkexComSvc.exe (an ASUS file) solved the problem of Firefox being blocked by MBAE.  If I get a reproducable fix, I'll come back and re-post.

 

Optional Info

  • It appears I had disabled MBAE, and that state persisted across reboots.  Thus, I wrongly thought MBAE was no longer blocking Firefox.
  • I found this out a while ago, but am just now gettting back to share the correction. 
  • Lame, I know, but I've been busy.  Sorry for the false report.
  • Even with disabling all the ASUS services listed in post #38, MBAE still blocks Firefox.
  • I found the suggestion in post #34 to disable Anti-HeapSpraying Enforcement for browsers.  I did that.  MBAE now doesn't block Firefox.
  • I haven't yet tried disabling the DisplayFusion services, to see if that is the cause.

Share this post


Link to post
Share on other sites

Bummer, but thanks for following up SoCalSienna.

 

Can you test by disabling all Firefox plugins and testing again to see if a plugin is causing this conflict?

Share this post


Link to post
Share on other sites

... test by disabling all Firefox plugins ...  see if a plugin is causing this conflict?

Conflict still occurs with all plugins/extensions disabled.

Share this post


Link to post
Share on other sites

I'm having the same problem. Works fine for days then suddenly when I try to open the latest Firefox it's blocked.

Using the latest free version of MBAE.

 

I can't see the option to attach the logs here?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.