Jump to content

AutoUpdate is turned off - yet Contacting server

Recommended Posts



since the last update I have noticed the following:
When I start the program, it takes a one-time connection to ( ec2-52-5-254-24.compute-1.amazonaws.com) on.


This only happens when I put it longer (a few days) not have used.

Auto Update is turned off!

Link to post
Share on other sites



Welcome. :)
AFAIK, that is normal behavior and nothing to worry about.
There are other reasons for which the program needs to phone home, in addition to update checks.
Having said that, it's not advisable to disable auto-updating for MBAM Premium.
The primary benefit of MBAM Premium is the real-time protection against zero-hour and zero-day threats often missed by a standard anti-virus.
In order to stay updated, it's important to schedule MBAM automatic update checks for database updates every 1 to 4 hours.

The update checks run silently from the system account and need not interfere with other computer usage.

Disabling that feature largely defeats the purpose of running MBAM Premium. :(

More info about v2.1.6 HERE
User Guide ONLINE
User Guide PDF
FAQ: Common Questions, Issues, and their Solutions


Thank you,

Link to post
Share on other sites



Again, as already mentioned, it is part of normal MBAM operations and is not directly related to "auto-updates", nor to the Paid or Free version, per se. :)


More information here:


and this much older thread here:


which links to this similarly old thread at Wilders:



Thank you again,

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.