Jump to content

Malicious Website not enabling, tried everything already

Recommended Posts



  After following all instructions on this website, I still cannot get Malicious Website to enable.  I am using Windows Server 2003 SP 2.  Seems like reinstalling, updating the database, etc. has worked for people, but none of that has changed my situation.  I have done reinstalls, clean installs, rebooting, updating, nothing has worked.  Problem only started about 3 days ago.  I feel like the problem may be the fact I'm using a 64-bit system.  Maybe I need the business edition for a MS Server OS?  There must be some bit of info I am missing.  I have the newest database and software update.  Thanks


Link to post
Share on other sites

Hello and :welcome: :


Correct -- MBAM (consumer version) installation is not officially supported on MS Server (though I'm told some folks are able to run it); the 64-bit architecture of your older OS is likely the other problem, especially for the Malicious Website Blocking module.

Also, the latest version of MBAM for Business or Enterprise is version 1.75, not version 2.x


As use of MBAM on a Business computer requires appropriate licensing, your best bet would probably be to log a ticket at the Business Help Desk >>here<<.

They can assist you both with technical issues and with arranging appropriate licensing.


Thank you,

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.