Jump to content

New Version Will Not Install

Recommended Posts

I received the "New Version" notification when I started Malwarebytes and it bombs out at the last screen on the install questions. It says that on the advanced settings to disable the "self protection mode"  I disabled the "Self-Protection Module" box... even rebooted the computer... and it still tells me to disable what is already disabled.


So... I disabled all the boxes in the Advanced Settings, and still the same problem. So....


First, which boxes should normally be checked, or what are the default boxes?? I didn't keep track of what seemed to be the default choices..


Secondly, is everyone else having this problem or only me?


Is the Anti-Exploit causing the problem?


Did I somehow piss off the computer gods in some mysterious way?


Does MalwareBytes Anti-Malware just not like my computer?


Am I going to go through life with V2014.10.13.10 and never be able to update?


Do you, just maybe, hopefully, have a "new" version that will install?


Any help from either MalwareBytes.org or local wizards would be most appreaciated.




NathanielA in Oceanside, having to live with large, angry letters saying,


"Your Program Is Out Of Date"


Oh, and that wouldn't be so bad, but I live in a 55+ community with about 932 homes and someone is putting flyers on everyone's door telling them that I'm a second class computer user who can't upgrade his MalWareBytes Anti-Malware (premium) program and they're starting a petition to make me move out in disgrace if I can't upgrade my program "soon", whatever soon means. So, please help. :)

Link to post
Share on other sites

Hello and welcombe :

If rebooting doesn't resolve your issue:

  • Please follow the steps in this pinned topic to uninstall your current version of MBAM and reinstall the latest build - MBAM Clean Removal Process 2x
  • If that does not correct the issue, then please read the following and post back attached to your next reply the 3 requested logs - Diagnostic Logs (the 3 logs are: FRST.txt, Addition.txt and CheckResults.txt)
  • NOTE: There is an FAQ section with valuable information located here - Common Questions, Issues, and their Solutions

Please let us know how it goes.


Link to post
Share on other sites

I'm sorry for the trouble you went to... but I have no idea where all these files are that I'm supposed to use... and I don't feel I should have to go to a lot of trouble if there are install bugs in the latest version. I find it hard to believe that I'm the only one with this issue... and if I am, then I don't feel it is somehow my problem if the install program fails to work when I "stopped" the self protection choice.  Hopefully the programmers will either fix the problem or they will issue a "fix" in a program that will sniff out their programming error and fix the installation routine so I can use the latest version.  If it turns out I'm the only one... then I'll just have to stop using MalwareBytes.org products as all can assume is that there is some incompatibility with their programming and my XP Pro, 32bit program that otherwise seems to get along with well written programs. I guess I'll also have tocancel my anti-exploit program becuse maybe it's somehow causing my problem. :(


That's my story and I'm sticking to it.!!

Link to post
Share on other sites



I suggest that you please take your time to read the advice/instructions in the pinned topics the links for which are in my previous reply. :)

Those steps get most users with minor issues up and running the fastest.

It's not as hard as it looks -- it's broken down into small steps with precise instructions.

Perhaps it might help to print them out first?

I would suggest starting by clicking the link for the pinned topic >>IN THIS LINK RIGHT HERE<<.


As we are not in front of your computer, basic troubleshooting -- starting with a clean reinstall -- is the only thing anyone could suggest in order to assist you.


If you prefer, instead, you may wish to open a ticket for one-on-one free help via email.

To do that, please click >>this link right here<< to submit a help desk ticket.

A support team member will help you by email.


Thank you.

Link to post
Share on other sites

< kibbitz >

Hi Nathaniel,


Lots of patience is required, first.  I normally advise I fresh Windows boot before the upgrade run and one at the end.

A install over the top is normally all that is needed.

and having the Anti-Exploit is perfectly ok.  It does not have any bearing on the issue at hand.


I think at the very most you can just right-click on the MBAM icon on the taskbar, and select EXIT.


Then just go for a upgrade in place.


NOTE: SAVE the downloads to your system first.
Do not "run" them while in the browser program.
When presented with the option to Run or Save, you must select Save.

If you do not see save, then go with RUN.

1: Please do a Logoff >> Shutdown >> Restart so that Windows is in a new session.

2: Download and SAVE to your system the 2.0.3 version of Malwarebytes Anti-Malware just released from the link below:

3: Now run the setup:

For Windows XP, just double click on mbam-setup- and and allow to run.

Have lots of patience as the Setup runs.

I would suggest that when the install is completed, that you do one more Logoff >> Restart Windows so that all is finalized to storage.

Link to post
Share on other sites

Thanks to all. I finally solved it... all the rebooting, unfortunately, didn't help. But what finally helped was to go to the C:\Program Files\Malwarebytes Anti-Malware directory and pick the unins000.exe program to completely uninstall the program. I had first used the windows uninstall to no effect, and Uninstaller Pro didn't work.... I guess I should have know that only Malwarebytes' own uninstall program would work. Anyway, I ran their uninstall, then ran the latest version "2014.10.14.02" or rather the "mbam-setup-" installer file and then the install program worked without falling apart and saying that I didn't have the "self protection" box unchecked... which I did, but before it said I didn't... but when running the mbam-setup**** file it worked without the bogus message.  I don't think it should have taken this amount of futzing around, but glad it did work, and if anyone else has this same problem I hope they read this post and I hope it works for them.



Nathaniel in Oceanside, CA

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.