Jump to content

Database Update never updates or finishes

Recommended Posts

I am running on XPPro


All was working fine until I update to the newer version.



1. Real Time protection never turns on

2. Database update never updates or finishes the process

3. When I tried to Clear All logs it doesn't and the last log was from 9/14/14


From what I've been reading this is a known issue

Is it resolvable? if not then how can I reinstall the previous version?

Link to post
Share on other sites

Hello and :welcome: :


Each computer is unique.

Issues that sound "the same" often are not, especially on different versions of the Windows OS.

When you say "newer version", it's not clear: do you mean, or the new public beta,


Here are a couple of things to try:

  • Please carefully follow the steps in this pinned topic to uninstall your current version of MBAM and reinstall the latest build - MBAM Clean Removal Process 2x
  • If that does not correct the issue, then please read the following and post back attached to your next reply the 3 requested logs - Diagnostic Logs (the 3 logs are: FRST.txt, Addition.txt and CheckResults.txt)
  • NOTE: There is an FAQ section with valuable information located here - Common Questions, Issues, and their Solutions

Alternatively, you may wish to try the new public beta of  It does fix many different issues for some users.
Information and download link are here: Malwarebytes Anti-Malware 2.0.3 Beta 1
Known issues are here: Malwarebytes Anti-Malware 2.0.3 Beta 1 - Known Issues
Either way, it would probably be a good idea to cleanly upgrade, following the basic sequence here: MBAM Clean Removal Process 2x (you would substitute the version 2.0.3 beta download instead of the 2.0.2 download at the appropriate step).

And if the clean upgrade doesn't resolve your issue, it would greatly help us to see the diagnostic logs requested above, in step #2.
Please let us know how it goes.

Link to post
Share on other sites

  • 3 weeks later...

I am having the same issue. I did uninstall and reinstall, then the udpate worked. Now it won't update again...

Hi, and :welcome: , midwestdeb:

Sorry to hear you are having issues.

Each computer is unique.

Problems that sound "the same" most often are not.

The same is true for solutions.

They most often need to be individualized.

It is less confusing for everyone if we try to stick to "one user per topic".

Please start a NEW, SEPARATE topic using the cjfj.png button. (where we can help you in your own topic)

The staff and experts will be able to more easily provide both you and the OP with individual help to get you both up and running.

Thanks for your patience and understanding,


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.