Jump to content

Automatic update not working


Recommended Posts

Sometime in the last couple of weeks, my MBAM updates stopped working automatically.

Problem may have started with the update to version 2.0.2.1012

 

I have MBAM set up to check for updates on each boot.

Each day I start the PC and the MBAM Icon says databases are out of date.

Then I do a Manual update and it works OK until the next day.

 

Up until recently it all worked automatically.

 

MBAM Premium 2.0.2.1012

Windows 7 pro. 64 bit,

Running as Standard user.

Link to post
Share on other sites

Hello and :welcome: :

 

You said are you are running as a Standard user.

Did you also INSTALL from that account?

MBAM needs to be installed from an ADMIN account in order for the scheduled tasks (update checks and scans) to work properly.

So, you may need to skip down to step #1 below, in order to cleanly reinstall from a Windows Admin account.

 

Also, as an aside, checking for updates on reboot is not a good idea on most systems.

The computer is "busy" with many tasks and networking may not yet be fully operational when MBAM tries to phone home so early in the process.

The default setting of scheduled hourly update checks is probably a better plan; you can always do an "extra" manual update check right after booting, if you want.  That way, you will stay current with the 10 or more database updates every day that keep abreast of new malware variants.

 

Having said all that....

A couple of easy things to check:
>>First, please be sure your system date/time are correct.
>>Then, please be sure that your AV and firewall both give MBAM full permissions. It's possible that your AV or firewall might be treating the new build as a new program and may be blocking it -- the files that need to be excluded can be found HERE (just the one reply, not the entire thread). Please post back if you need help with that.
>>Also, please check to be sure there are no "Detected Threats" that need to be dealt with first, as this can prevent the program from updating: Click the "Scan" button at the top of the dashboard and verify that there are no detected threats (especially PUPs or PUMs) awaiting your actions.


If those suggestions don't resolve your issue:

  • Please follow the steps in this pinned topic to uninstall your current version of MBAM and reinstall the latest build - MBAM Clean Removal Process 2x
  • If that does not correct the issue, then please read the following and post back attached to your next reply the 3 requested logs - Diagnostic Logs (the 3 logs are: FRST.txt, Addition.txt and CheckResults.txt)
  • NOTE: There is an FAQ section with valuable information located here - Common Questions, Issues, and their Solutions

Please let us know how it goes.

Thanks,

Link to post
Share on other sites

  • 2 weeks later...

Sorry for the delay. I have been out of town.

I saw no special settings in the Windows 7 Firewall options, so I left it alone.
Yesterday I removed and reinstalled MBAM Premium from an Admin authority user on my Windows 7 PC.

I did disable MSE during the removal and install process.

Even though I used the MBAM-CLEAN program, I was not asked for my MBAM pro product key during or after the install. Somehow it remembered it.

I changed the update schedule from Boot to "Every 3 hours".

 

Today I booted up the PC and MBAM appears to have auto-updated itself OK.

Hopefully it will continue to do so.

I think this all started when MBAM pro ver 1 updated to MBAM premium ver 2.

Thanks for the help.

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.