Jump to content

Threat Scans consistently get caught on single files


Recommended Posts

Before MalwareBytes Anti-Malware 2.0, threat scans would normally take 8-30 minutes to complete. However, as of the update, scans now consistently get caught on single files, and scans are taking longer and longer to complete. Scans went from taking one to two hours to complete to three, and now this scan has been going on for four hours and thirty minutes. Please help me, my computer is old, and I cannot have intensive programs like MBAM take up valuable memory for extended periods of time.

 

Thank you.

 

 

Link to post
Share on other sites

Hi and :welcome: :
 
First: Multiple factors contribute to scan times.
These include:

Size of disk
Disk type
Disk speed
Disk caching
CPU speed
Controller type and speed
Operating System used
Amount of files (including temp files!)
Amount of folders
Amount of archived files such as zip, rar, sfx, etc. (if this is enabled)
Rootkit scan or not (if this is enabled)
PUM/PUP scans
Other security programs running at the same time that may potentially be monitoring all file accesses by any other process.
Drive integrity - if a drive is failing it can take a long time to ignore and bypass sectors on a disk or simply fail period and hang the scan.
Other ongoing disk I/O processes
System being infected can also affect speed of scans
Also note that changes in the MBAM database can also cause scan times to increase or decrease, so that's another factor to consider.
Sometimes a conflict with your antivirus may be possible as well. You may want to try adding exclusions in your AV - the files that need to be excluded can be found HERE. Let us know if you need more help with that.
 
Next, sometimes slowdowns are not due to conflicts between MBAM and the AV, per se, but rather to older hardware, insufficient RAM, cluttered disks, excessively tight security settings, or other factors.  You might want to have a look at this FAQ article >>HERE<< to see if the steps there resolve your issue.
 
Next, you might want to disable both archive and rootkit scanning, to see if that improves things -- let us know if you need help changing those settings.
 
If none of these resolves your issues, routine troubleshooting would start with these steps:

Thanks,

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.