Jump to content

All Buttons Grayed Out


wordsworth
 Share

Recommended Posts

I've been using the Beta version for a couple of months and yesterday installed the Premium version.  I don't recall the buttons being grayed out in the Beta, but in the Premium all buttons are, why? 

 

When I right-click the icon in the Notifications bar both Start and Stop Protection are grayed out.  In the program itself on the General tab, Stop Protection is grayed out, Shields tab all buttons are grayed out, Logs tab, Exclusions also.  I would think the Add Shield button would at least be operative so I can add one.  Am I missing something or should I re-install?

 

Also, I've read of "Profiles" for adding program shields, where are these?  Do you see them if the Add Shield button is operative?

Link to post
Share on other sites

  • Staff

Welcome to the forum and thanks for posting wordsworth.

 

The reason you are seeing the buttons greyed out is because your logged in user account is configured as a Limited User Account (aka LUA). If you log out and log back in with a user account that has administrator rights then MBAE's buttons and options won't be greyed out.

 

As for adding custom shields and their protection profiles you are correct, you will see this when you click "Add Shield".

Link to post
Share on other sites

Thanks for the reply and welcome.  It appears then that for these buttons to be actionable you must log in to your Admin account; you can't just right-click the MBAE icon in the Start menu and run MBAE as admin from your LUA.  Correct?  At least that's how MBAE currently works on my system.

Link to post
Share on other sites

  • Staff

Yes, you should be able to right-click on mbae.exe (the GUI) or its shortcut and choose run as admin. However keep in mind that mbae.exe runs at boot time under your user context automatically. So if you want to use the "run as admin" you need to first exit the mbae.exe that is currently running under your user account (right-click the icon in the traybar and choose hide) and then right-click on mbae.exe's shortcut and choose run as admin. Otherwise you'll be running a second instanace of mbae.exe and it will automatically close itself.

Link to post
Share on other sites

  • Staff

Short answer

Yes you are still protected if the buttons are greyed out.

 

Long answer

MBAE consists of two main components, a Windows Service (mbae-svc.exe) and a User Interface (mbae.exe).

  • The Windows Service runs as SYSTEM every time the computer boots. The service is the one that provides the protection and this is always running.
  • The UI mbae.exe is a front-end to the MBAE Windows Service. It is executed upon user login from the registry (HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run) and runs under the context of the logged in user. You can login to the computer with multiple users and each user session will have its own mbae.exe running. Ergo, MBAE works in server environments where there are multiple users logged in at the same time (Citrix, Terminal Server, etc.) as well as in a home computer where there are multiple users. But only admin user accounts can use the UI buttons to perform any maintenance tasks such as disabling shields, adding/removing shields, stopping protection, clearing the logs or adding/deleting exclusions.

 

Hope this helps clarify how it works.

Link to post
Share on other sites

Yes, you should be able to right-click on mbae.exe (the GUI) or its shortcut and choose run as admin. However keep in mind that mbae.exe runs at boot time under your user context automatically. So if you want to use the "run as admin" you need to first exit the mbae.exe that is currently running under your user account (right-click the icon in the traybar and choose hide) and then right-click on mbae.exe's shortcut and choose run as admin. Otherwise you'll be running a second instanace of mbae.exe and it will automatically close itself.

Thanks for this explanation and the further given to peters4000; it all makes sense now.  I usually don't go into the Admin account, maybe once a month, but prefer to do the right-click run-as-admin procedure to do maintenance, etc when it is needed.  I had not thought of using Hide Icon before trying to use the right-click run-as-admin procedure until you pointed that out.  All is well now.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.