Jump to content

Upgraded MBAM 1.x to 2.x and now the desktop icon is undeletable

Recommended Posts



Since I upgraded to MBAM 2.x, I can not delete the public desktop icon.

Windows 7 SP1 PRO x64 FrenchMalwarebytes Anti-Malware PRO (Paid version)

In a administrator CLI :

C:\>del /F /Q "C:\Users\Public\Desktop\Malwarebytes Anti-Malware.lnk"C:\Users\Public\Desktop\Malwarebytes Anti-Malware.lnkAccès refusé.
"Accès refusé." mean "Access denied".
C:\Users\Public\Desktop>icacls ".\Malwarebytes Anti-Malware.lnk".\Malwarebytes Anti-Malware.lnk BUILTIN\Administrateurs:(I)(F)                                AUTORITE NT\INTERACTIF:(I)(RX)                                AUTORITE NT\Système:(I)(F)                                aal-PC\aal:(I)(DE,DC)1 fichiers correctement traités ; échec du traitement de 0 fichiers
C:\>icacls /? [...]DE - SuppressionDC - Suppression de l’enfant[...]

"Supression de l'enfant" mean "Supression of the children".

So, I'm supossed to be able to delete the file, but can't...


The user "aal" is in the admin group:

C:\Users\Public\Desktop>net localgroup AdministrateursNom alias       AdministrateursCommentaire     Les membres du groupe Administrateurs disposent d’un accès complet et illimité à l’ordinateur et au domaineMembres-------------------------------------------------------------------------------AdministrateuraalLa commande s’est terminée correctement.

Even tried to suppress it with an admin Cygwin shell:

aal@aal-PC /cygdrive/c/Users/Public/Desktop$ rm Malwarebytes\ Anti-Malware.lnkrm: impossible de supprimer « Malwarebytes Anti-Malware.lnk »: Permission denied

"impossible de supprimer" mean "impossible to suppress"


Unlocker was not able to delete the file. Even at reboot. 




The file is on a clean SSD (no bad cluster).

The computer is not infected at all and was not infected in the past.

Tried to delete the file without MBAM running and did not work either.

I have the problem with this only file.


Is this a bug from the upgrade?

How can I delete it within Windows? (I know I could use a live boot CD/USB key with Ubuntu (for instance) to delete the .lnk, but I want to know what happend...)





Link to post
Share on other sites

It sounds as if you may have MBAM Self-Protection enabled.
Doing so blocks deletion of the shortcut icon.
Please see if this explains and resolves your issue: Why can I no longer delete my MBAM 2.0 desktop shortcut icon?

ALSO, for additional information:
There is an FAQ Section here: Common Questions, Issues, and their Solutions
And here are links to the MBAM 2.0 User Guide: Online and PDF
And there are many useful KB topics and videos at the helpdesk support page



Link to post
Share on other sites

Wow! That did the trick!


FYI, I had to reboot after unchecking the self-protection module.

Just as the article said: "In some cases, a restart of the computer is required before you can remove the icon".


I can say that the protection module really works ;).


Very good and fast support, thanks!
Have a great day.
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.