Jump to content
pbmcmlxxi

Nitro PDF / Nitro Reader Support

Recommended Posts

In the new version 1.03.1.1220 Premium you can add custom shields.

Share this post


Link to post
Share on other sites

Seems this wont work to protect nitro 3 as a custom shield, there are 6 .exe files in the folder & I've tried adding each one, none of them work, including the most obvious & the one I think should be added, NitroPDFReader.exe

I added custom shields for both thunderbird & libreoffice, both of those popup the protection notification when started, all good :), nitro does not :(, no matter which of their files I add.

 

Hopefully it does actually work & I have simply overlooked something, help would be appreciated please.

 

Cheers

Share this post


Link to post
Share on other sites

I should have included that is on win7

 

added faststone image viewer also with no problem.

 

Tried adding nitro on a win8.1 system, no luck there either

Share this post


Link to post
Share on other sites

Enable MBAE log protection events and then look at what is listed after you have run NitroPDFReader.exe.

Share this post


Link to post
Share on other sites

Hi Freewheelin. Please post your MBAE data folder. Instructions can be found in the "readme first" link in my signature.

 

Thanks!

Share this post


Link to post
Share on other sites

Interestingly it only shows as injected when shielding "Nitro_PIPAssistant.exe" instead of the other NitroPDF executables.

 

Can you get a capture with Process Monitor during the normal startup process of NitroPDF? With that we might be able to see how Nitro starts itself exactly.

Share this post


Link to post
Share on other sites

After spending 20 minutes trying to do something I had never done before I have the attached file but don't know if that is what you  need/asked for, would be nice if malwarebytes provided a step by step to save us time when we are troubleshooting the program for them.

 

Having said that, it does indeed seem to be working now when I add Nitro_PIPAssistant.exe, no idea why it did not the first time I tried it, so thanx for that, I think I am set now, & hope the file helps you further.

 

cheers

 

PS. Got this message from your forum software: "Logfile.PML You aren't permitted to upload this kind of file" - so I simply changed the file extension to .txt

Logfile.txt

Share this post


Link to post
Share on other sites

Thanks for the log and the time troubleshooting. Sorry about not providing more detailed instructions up front, but glad you got it working now! :)

Share this post


Link to post
Share on other sites

Hi, I'm running Nitro Pro 10 on Windows 10 and I've tried both nitro_pro10.exe and NitroPIPAssistant.exe, and nothing is showing up in my logs.  I also get a notification when other programs like Chrome are being protected.  I get nothing when I open up Nitro Pro.  

If anyone has any ideas, I'm all ears.

Thanks

 

 

Edited by Diotallevi

Share this post


Link to post
Share on other sites

Hello Diotallevi,

Can you check to see if there is any background processes of Nitro running when you are testing this? This sounds like a common thing that normally users of google chrome runs into. Because it keeps a process of google chrome running in the background, we are still protecting it. So even though a new window is opened, it won't show the alert that it is being protected. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.