Jump to content

Crash When Database Update Attempted

Recommended Posts

Issue Summary:

  • MBAM application crashes immediately when a database update is attempted
  • Windows Error: "Malwarebytes Anti-Malware has stopped working"

Software Details:

  • Original Program Version:
  • Current Version:
  • Operating System: Windows 8.1 Enterprise x64 Update 1
  • Latest MS Updates installed as of this posting


Steps Taken:

  • Clean uninstall/reinstall of the application at build 1004 using MBAM Clean
  • Scanned system with MB Anti-Rootkit (after normal boot, and again in safe mode, using latest database version); Results came up clean
  • Tested booting system with all non-Microsoft applications and services disabled on startup
  • Tested with all firewalls completely disabled
  • Performed additional uninstall/reinstall with MBAM Clean, installing latest build (
  • Verified that Windows date/time is accurately set

Logs Attached:

  • MBAM Check Log File
  • MBAM Protection Log XML File
  • FRST Log File
  • FRST "Addition" Log File
  • Screenshot of App Crash for reference (PNG Image File)
  • Windows Application Crash "WER" Files from 2 earlier-occurring crashes
  • msinfo32 NFO File, for full details of the environment including installed software (password protected ZIP file; support can direct-message me to request the password)


I appreciate any assistance that can be provided on the issue. I've seen several others with the same problem, but haven't had any luck with recommendations I've seen posted on their threads. I've also opened up a support ticket that's been open for a couple weeks, but progress there has been slow and we seem to be running in circles at this point.


FYI, I'm an IT professional in enterprise technical support with a relatively high skill level. If there are any advanced steps that need to be performed at the request of developers, I shouldn't have any trouble with them.


Also, I'd highly prefer not to have to reinstall my operating system (at least not until my next major hardware upgrade in this workstation), though I'm not opposed to testing on a "clean" OS install, which I could implement on an external drive if needed.








Link to post
Share on other sites

Hello and :welcome:

Looks like you have done some pretty good trouble shooting there. We will have to wait for someone on staff/development team to review your logs see if they can figure out whats going on.

That being said, perhaps you have a similar problem as this person HERE, maybe you can backup your net.conf file and download and try the one in that post to see if it helps. (not saying this is the fix, but perhaps it wont hurt, just make sure you backup yours first).

Link to post
Share on other sites

Thanks for the suggestion - I'll see if I can get a net.conf file from a working system to test.


I suppose I should also grab a Wireshark capture and Process Monitor logs as recommended in that other post as well.


Thanks for the input!

Link to post
Share on other sites

Sure enough - the net.conf file was the culprit.


I installed Malwarebytes on an alternate system (a virtual machine on this same box in fact), and saw that it worked fine. I made a backup of my net.conf file and tested with a copy from the alternate system, and updates now appear to work flawlessly!


Good & bad net.conf files are both attached in case any staff or devs want to have a look. Feel free to contact me if any other info is needed, I'm more than happy to help pull more info to help track the cause of the problem/bug.


Link to post
Share on other sites

  • 3 weeks later...

I'm having the same issues on a Windows 7 Ultimate 64 bit machine whereby the MBAM 2.02 app crashes when attempting to Update. Can you please detail the steps needed to correct the net.conf file?



To Steve:


First, ( but only if the program is running) lets shutdown the realtime Malwarebytes Anti-Malware. Go to the desktop Taskbar. See the blue-color MBAM icon in the notification area.

Do a Right-click on it with your mouse, and select EXIT.

I have attached a zip file which you need to Save to your system.

Once saved, unzip it to extract all contents.   which will be 2 files.

Next, double-click on **net_replacement.bat** file.

It should run fairly quickly in a command-prompt window.

Once that is done, restart the Anti-Malware and let me know if it works normally.


Link to post
Share on other sites

Must be an IE11 conflict (or setting) in the Forum software here that prevents me from quoting a post. I've seen that in another forum running the same software.


In any case, thanks to Maurice for your solution....worked perfectly on a desktop running Windows 7 64 bit Ultimate.

Btw, can you elaborate on the particular files that were changed in your attachment above pls?


I should have mentioned that I had previously installed the new MBAM version successfully on two Windows 7 64 bit Home premium machines without incident, as well as today on a Windows XP older laptop, also without any issues.

I have been using MBAM for many years now and it is a GREAT product that has helped me with many malware issues on numerous machines.


Thanks again and rgds.



Link to post
Share on other sites

Hi Steve,


The "issue" does not happen to everyone.  Matter of fact, it is in the minority when compared to all of the population who have done the new version.

The file replaced here is just 1 configuration file.


I am glad to know yours is fine at this time.  :)

Link to post
Share on other sites



Just wanted to let you know I also had the identical problem.  After installing 10-15 times I was ready to give up thinking my ops system had a malfunction.  So I submitted a ticket and that's how I found the forum.   This thread was exactly my problem.


HP Laptop

W7 32 bit


I transferred your file to a mem stick and then inserted it in the laptop.  Open the files right on the stick and double clicked on the bat file and it worked.   Just thought I would let you know that this problem may be bigger than you think.   I assume the developers will patch the software eventually.

Link to post
Share on other sites

  • 3 months later...

The best remedy is ( at this time) to get the Release Candidate 1 which is Version

See the announcements on the forum




This version of 2.0.3 is now what I would recommend, until the final general Released version is available.


Link to post
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.