Jump to content

Tried upgrading to MBAM 2, eventual fail, "System Error"


Recommended Posts

MBAM (Pro) had been nagging me to upgrade to v2 for some days, finally I decided to try (a fresh install) of it on my XP machine, first.  Everything seemed to go correctly, I even enabled the self-protection module, and my license key was accepted and it's still all fine.

 

Then I decided it's probably safe to upgrade to v2 on my Win7 32-bit machine: no.

 

I let it perform the update it kept giving me pop-ups about, upon starting the program etc., instead of trying to uninstall it first or anything.

 

Everything looked fine at first, it even survived a reboot and preserved my pro license for the box, but then after enabling the self-protection service thing and rebooting another 1 or 2 times, it wouldn't start.

 

When I try to start MBAM -or- the 2.0.1.1004 installer, I get this error window jazz:

 

mbam.exe - System Error
 
The program can't start because
API-MS-WIN-Service-Core-L1-1-0.dll is missing from your computer.  Try reinstalling the program to fix this problem.
 
 
well, the installer causes that error now, I think my PC may be acting funny in other ways since this happened as well but MBAM is the only thing .
 
I wonder if there's some way for this to work as intended, for me, Is this a known problem?  Should I try to uninstall, then install v1.7 again and just un-check the program updates?  Is there some way to manually de-select the self-protection service thing, if I assume that's the problem?
 
Thanks in advance
 
 
Link to post
Share on other sites

Hello and :welcome:

Thank You
Link to post
Share on other sites

I wonder what the name is for the self-protection service.  It would be nice if I could disable it without being able to start the program.  After reading that FAQ page I suspect that the "self protection" is a big part of the problem, and I wish I'd had the option of turning it off before everything went bad.

 

I wonder if I have to have some other service enabled for this to work which I currently have disabled, like Application Layer Gateway Service or Application Management.  I usually disable a lot of services that don't seem to matter very often.

 

I tried to run the cleaner utility to remove everything and then tried to install the 2.0.2 beta but nothing seems to have changed; I still get the same error message.  I noticed the program files are still there, though it's not listed in programs to uninstall.

 

When I first ran the mbam-clean-2.0.2.0.exe I got this error:

 

Application Error:
 
Exception Exception in module unins000.exe at 00055E61.
CoInitialize failed (0x8007000E)
 
Then I rebooted and tried it again, right-clicking and choosing to run as Administrator just in case it didn't previously escalate, and got:
 
unins000.exe - System Error
 
API-MS-WIN-Service-Core-L1-1-0.dll is missing from your computer.  Try reinstalling the program to fix this problem.
 
Then I got that error again when I tried to run unins000.exe from the program folder directly.  Then I got it again, but with a different title when I tried to run mbam-setup-consumer-2.0.2.1007.exe
 
Note: it did prompt me to reboot both times that I ran the mbam-clean utility, though the error windows were there too.
 
Thanks for the ideas and links, guys
 
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.