Jump to content

[SOLVED] Slowdown/FPs with Java-based apps


yigido
 Share

Recommended Posts

  • Replies 101
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

It's a known issue sometimes with the Java shield. It is fixed in version 1.04 which I will send you via PM so you can verify that it is fixed.

 

Btw I'll also merge this post with the existing thread for the Java FP/Slowdowns.

 

Well, The other issue is that i can't seem to disable it, Turning off the program causes it to still block things, And it won't respond to Task manager's attempts to close it

Link to post
Share on other sites

  • Staff

Hi Tiare, some questions please:

 

1- How are you trying to disable it? Optios are right-click on the traybar icon and clicking stop protection, opening the GUI and clicking stop protection, or stopping the windows service.

 

2- If you want to close mbae.exe (the MBAE user interface) from the TaskManager you may have to open TaskManager as admin user. But it is easier to simply right-click on the MBAE traybar icon and choose Hide Icon. If what you are trying to close is mbae-svc.exe (the MBAE protection service) then it is simpler to right-click on My PC, then Manage, then Services and then locate and stop the "Malwarebytes Anti-Exploit Service".

Link to post
Share on other sites

I just tried a Java update but AE blocks the update process. The Exclude button is greyed out and I can't seem to change this any way. Can someone tell me how I can allow Java, via cmd.exe, to update?I know all the problems surrounding Java but that is not the issue. I want Java to update so I always have the latest one installed. Blocking updates simply compounds the problem.

Link to post
Share on other sites

Hi all,


When using Eclipse with MBAE installed and running, I tried to run Maven via Eclipse. It was blocked as an exploit. I looked into the Logs, and the exploit was "cmd.exe blocked from executing through Java". The path I used to run Maven was: RightClick on project file-Run As-Maven Install. I ended up temporarily disabling MBAE and then it worked fine.


-Joe Warreb


Link to post
Share on other sites

  • Staff

Hi Joe, this is a known issue with MBAE 1.03 which has been fixed in MBAE 1.04. I'll send you a PM with a link to download and install 1.04 to verify that it is in fact fixed.

 

Btw also merging your post with the existing thread about this issue.

Link to post
Share on other sites

Hello,

 

MAE Premium 1.03.1.1220

Arduino 1.05-r2 downloaded from http://arduino.cc/

 

When I Upload the Example, Basics, Blink file, it gets stuck at Compiling... then eventually MAE blocks it. I Excluded it to no avail. :mellow:  If I turn off MAE, the example runs fine.

 

I've attached images of the MAE Log and Exclusions.

 

Here's the code:

 

/*
  Blink
  Turns on an LED on for one second, then off for one second, repeatedly.
 
  This example code is in the public domain.
 */
 
// Pin 13 has an LED connected on most Arduino boards.
// give it a name:
int led = 13;
 
// the setup routine runs once when you press reset:
void setup() {                
  // initialize the digital pin as an output.
  pinMode(led, OUTPUT);     
}
 
// the loop routine runs over and over again forever:
void loop() {
  digitalWrite(led, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);               // wait for a second
  digitalWrite(led, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);               // wait for a second
}
 

post-167894-0-66581700-1407553797_thumb.

post-167894-0-01045800-1407553800_thumb.

Link to post
Share on other sites

  • Staff

The person who can best answer this issue may not be available quickly to answer it, but please be assured that he will respond as soon as he checks in.  I will ping him so that he is aware of the issue.

Link to post
Share on other sites

  • Staff

Welcome to the forum and thanks for posting.

 

Can you please attach your MBAE log files as per the instructions:?

[README FIRST] How to post here

 

Also after attaching the logs here, please uninstall MBAE, reboot and then install the upcoming MBAE 1.04:

https://malwarebytes.box.com/s/zem0549df4wxtxdwwx5o

 

Does this solve the problem?

Link to post
Share on other sites

Welcome to the forum and thanks for posting.

 

Can you please attach your MBAE log files as per the instructions:?

[README FIRST] How to post here

 

Also after attaching the logs here, please uninstall MBAE, reboot and then install the upcoming MBAE 1.04:

https://malwarebytes.box.com/s/zem0549df4wxtxdwwx5o

 

Does this solve the problem?

Here is all the logs before I remove AE

Desktop.zip

Link to post
Share on other sites

  • 3 weeks later...

Hello, I recently started using Malwarebytes Anti-Exploit just to test it out and get some more protection on my PC. Since Malwarebytes Anti-Malware is so good, maybe this will be too.

 

Anyways, up until now I have had no problems. The issue is, whenever I try to launch Java Update Anti-Exploit says "Exploit Attempt Blocked!" "Anti-Exploit has blocked an exploit attempt". In order to check for Java updates I have to shut off Anti-Exploit. Is there a way to fix this? I would prefer to not shut off Anti-Exploit every time I check for updates to Java. Also, could my Java Update be infected? Unsure why it reports Java Update as an Exploit.

 

Other Info:

 

I open the Java Control Panel, and select "Check For Updates". This is usually when UAC asks me if Java Update has permission to run. Instead of this Malwarebytes Anti-Exploit pops up, closes Java Control Panel and reports the exploit.

 

Windows 8 64 Bit Home Premium

6 GB RAM

Intel Core i3 @3.4GHz

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.