Jump to content

alcor micro usb 2.0 card reader not working on windows 7


Recommended Posts

OK, installed MBAM PRO on a lot of laptops.......DELLS, HPs, Lenovos.  Had one issue on the Lenovo B570s in that MBAM conflicts with the Lenovo Security Center & Port Blocker Software.....we are going to uninstall the Lenovo stuff and confirm....seems this is known issue.

 

This thread is about four HP DM4 laptops we have.  We noticed that when we insert a SD card it works on first try.  A re-insert gives us a bad "bong" and when we look into device manager the Alcor Micro USB 2.0 Card Reader has yellow exclamation point.  Opening properties it says that the driver cannot be loaded because there is already an instance in memory.  If we reboot the machine it works fine for first time again, any retries and no-go.  I found a thread on the Microsoft Community Forums (Googled) where person had same problem and found to be the MBAM Service.  I did stop service in Task Manager and no change, did a uncheck of MBAM in MBAM for protective no change, did a right click on MBAM icon in tray to not have start at Windows, reboot, worked first time but then same error.  I then uninstalled MBAM and guess what...problem went away.  Re-install MBAM...problem is back.  In device manager I did right click and try update driver...Windows came back and said this was latest I have installed.

 

This is not a super critical issue but having to reboot to get SD card to work is a pain.
Note, USB sticks, even USB external HDD have no problems.

 

Please let me know your thoughts or what to try ?

Link to post
Share on other sites

  • Root Admin

As a Business customer your best bet it to probably work with Corporate Support and see if they can assist you with this issue.

Not sure why but pretty odd to have 2 different computer MFG and 2 different seemingly rare issues. I don't recall having seen this issue ever posted here either.

Link to post
Share on other sites

  • Root Admin

Well any type of business use requires a business license which also requires a yearly renewal.  The Consumer Retail license is not for use in any type of business.

 

As for those errors as I said I've not seen them posted here before.  The only similar post here that I'm aware of is a lock or freeze on Toshiba and Lenovo due to their own built-in security software which is not what you've posted about in either case.

 

I can leave the topic open if you like but for real support on the issue the Helpdesk would probably be the best choice.

 

Thanks again

Link to post
Share on other sites

**** RESOLVED ****

 

Well, the issue is resolved. 

The USB Card Reader (as posted) in this HP DM4-1265DX is Alcor.

I had the v1.0.14.52 August 2010 driver installed....went to HP site and there was never (Dec-2010) v1.0.23.67.

So, went ahead and installed this new driver, reboot, first time insert of SD Card worked (as always), eject, re-insert many times.....works fine.

I read the version notes and it only says this driver is to support more HP models.

So, not sure if they "fixed" something or the installing process of the driver itself did the trick.

I say the later because when I inserted the SD Card for first time after driver install W7 did the icon tray "installing device driver" thing.

So, if anyone reading this post in the future has same issue I'd suggest two courses of action....

1) Look for latest driver of card reader and install

2) If there is no "latest" version then get executable install version of your current driver.

    Go to device manager within control panel > system and right click on usb card reader (card needs to be inserted to see),
    go to properties, then driver tab, then uninstall.....follow instructions.  Then go to the executable of driver you have and install.
 

I'm not 100% sure but for some reason MBAM may have corrupted the USB card driver......very strange.....since when I uninstalled MBAM it had started working again.  Thus, I'm guessing that perhaps the solution is not a "new' driver but perhaps the clean re-install.  Also note, as stated in thread the disabling of MBAM service did not make this work again, but the uninstall did.

 

You can close thread and marked as solved so others can search on it.

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.