Jump to content

How do I convert this to a REG merge file?


ShyWriter
 Share

Recommended Posts

The following code by MVP AceInfiniity from the sysnative.com Forums creates a right-click-take-ownership command and icon in the right-click menu for Win8/8.1

 

What do I need to do to convert it to a registry-merge file?

Windows Registry Editor Version 5.00[HKEY_CLASSES_ROOT\*\shell\runas]@="Take Ownership""Icon"="imageres.dll,-106""NoWorkingDirectory"=""[HKEY_CLASSES_ROOT\*\shell\runas\command]@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F""IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"[HKEY_CLASSES_ROOT\Directory\shell\runas]@="Take Ownership""NoWorkingDirectory"=""[HKEY_CLASSES_ROOT\Directory\shell\runas\command]@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t""IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"

Thanks in advance,

BTW, the right-click-reg-fix @porthos posted in a previous message for Vista/Win7 also works for Win8/8.1 but doesn't allow choosing any particular icon.,

Steve

 

Link to post
Share on other sites

Copy the code inside the box into a TXT file.  Save and rename the file to .REG.

 

One way is to Right-Click within a folder.  (I'm demonstrating on my Desktop)

Choose;  New --> Text Document.

post-14644-0-07260900-1384116267.jpg

 

Then Double-Click on the file "New Text Document.txt" and paste the code into the file and Save (Ctrl-S).

 

Then rename "New Text Document.txt" to something like "RunAs.REG".

post-14644-0-26494000-1384116267.jpg

 

NOTE:  It is suggested for this and in general practice and operation to make sure Folder Option "Hide extensions for known file types" is NOT enabled.

Link to post
Share on other sites

Thanks David,

It's been so long since I did one but your explanation/pix brought back memories. I appreciate the instructions.
 

NOTE:  It is suggested for this and in general practice and operation to make sure Folder Option "Hide extensions for known file types" is NOT enabled.

 

Never is enabled on any of my machines.. :)

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.