Jump to content

Firefox tab issue


fivealive
 Share

Recommended Posts

I have firefox set to save my tabs when  close firefox and when I open it again it is supposed to open all the tabs exactly where I left off, well these last few days I have noticed that, it is not restoring my tabs to the last spot I was on the webpage, instead it is loading it at the top of the page, I have no idea how to fix this inconvenience.

 

I posted on the firefox forums, but I was told to uninstall firefox, which isn't helpful. I would like to restore all my login sessions and history as well as addons. but I have no idea how to go about that.

 

The trouble shooting steps I found, create a new profile, but none of my addons and login information is saved.

Link to post
Share on other sites

Hi, fivealive:

 

"Tabs on Top" is the default setting in Fx, dating back several versions.

 

The setting might have reverted when you recently upgraded to Fx 25 or installed an extension (especially those that manage tabs), or some such.

 

It's easily remedied.

Just un-check the option in the context menu in the attached screen shot, then close Fx and reopen it.

NOTE: The option to do this was actually removed a while back. So, if you have newly installed Fx from scratch with a brand new profile, this option from the context menu might not be available.  (If you used that setting in a prior version, it will be "respected" when you upgrade the program and use an existing profile -- that's what you're seeing in my screen shot.)

 

If that doesn't solve the problem, try the standard diagnostics, beginning with Mozilla safe mode: http://kb.mozillazine.org/Safe_mode.

OR, you can go into about:config and toggle the setting.  Here's how:

 

 

Type about:config into the address bar and hit enter. Press "I'll be careful" on the silly warning page and find this preference: browser.tabs.onTop

There's a filter near the top to help you find it easier.

Double click it to change it from true to false. The tabs should instantly go back to the bottom.  http://forums.mozillazine.org/viewtopic.php?f=38&t=2624621

 

((BTW, creating a new profile is just a diagnostic move and is not unreasonable to try. But it makes sense to try Mozilla Safe Mode first.  If a new profile fixes the problem -- whatever it might be, not just this issue, then you know the problem was something in your profile; this is the case >90% of the time when there are "issues" with Fx.  Then you import your saved bookmarks and start to install extensions one by one. If the/a problem returns, then it's isolated to that new extension.))

 

HTH,

 

daledoc1

post-29793-0-96151800-1383566589_thumb.p

Link to post
Share on other sites

Thank you, I checked that option its not listed  under options but I checked the about:config and its set to true. it turns out its a series of sites thats the issue, because it works on any other website but this group, which is operated by the same person, turns out they changed something. I did clear out the cache and cookies and that seemed to have fixed some other minor bugs I was getting.

 

thanks

 

fivealive

Link to post
Share on other sites

Hi, fivealive:
 

Thank you, I checked that option its not listed  under options


Then you are either working with a new Fx install and/or a new profile.
I had a feeling that might be the case for you, so I mentioned the other "fixes" and workarounds for the issue.
As I mentioned, that option was removed a while back.
But if one had it in place from an earlier version, the setting would be respected and maintained with subsequent version upgrades.
I think that's why I still have the option in my context menu and you don't.

 

but I checked the about:config and its set to true.


If you DON'T want "tabs on top", you would want to toggle that setting in about:config to "false". :)

 

it turns out its a series of sites thats the issue, because it works on any other website but this group, which is operated by the same person, turns out they changed something. I did clear out the cache and cookies and that seemed to have fixed some other minor bugs I was getting.

 
Hmm, that's pretty weird.
I'm no Mozilla script kiddy or Fx power user.

But I'm not sure how a website would change your "tabs on top" preference in your profile?
I suspect that something else you did may have altered your profile settings?
 
You might want to run this by the geeks at the mozillaZine forum?

FWIW, this independent user community unaffiliated with Mozilla is MUCH more active than the forum at the mozilla web site or even their support site.
You are much more likely to get a quick reply from a guru or true power user (though it can't hurt to ask at the Mozilla foundation sites, too).
 
In any event, I'm glad your problem is resolved, :)
 
daledoc1

Link to post
Share on other sites

Hi, fivealive:

 

Then you are either working with a new Fx install and/or a new profile.

I had a feeling that might be the case for you, so I mentioned the other "fixes" and workarounds for the issue.

As I mentioned, that option was removed a while back.

But if one had it in place from an earlier version, the setting would be respected and maintained with subsequent version upgrades.

I think that's why I still have the option in my context menu and you don't.

 

If you DON'T want "tabs on top", you would want to toggle that setting in about:config to "false". :)

 

 

Hmm, that's pretty weird.

I'm no Mozilla script kiddy or Fx power user.

But I'm not sure how a website would change your "tabs on top" preference in your profile?

I suspect that something else you did may have altered your profile settings?

 

You might want to run this by the geeks at the mozillaZine forum?

FWIW, this independent user community unaffiliated with Mozilla is MUCH more active than the forum at the mozilla web site or even their support site.

You are much more likely to get a quick reply from a guru or true power user (though it can't hurt to ask at the Mozilla foundation sites, too).

 

In any event, I'm glad your problem is resolved, :)

 

daledoc1

 

 

The websites in question wouldn't let people copy and or paste any text on the website, turns out it was in error, and the people on the forums there, think it might be causing the tab issue as well.

 

 

on another note, this profile is not actually new, its many months old, back in march I got a new hard drive for my laptop, and what I did was copied the mozilla profile folder from appdata, on reinstalling windows onto the laptop I just dumped the folder back into appdata after installing firefox.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.