Jump to content

Automation Error

Recommended Posts

Hello all

I am in the throes of rebuilding my pc with XP Pro SP3.

Suddenly the Help & Support option on the Start Menu stopped working. In my investigations I came across a forum

post that this may be due to malware and it was suggested that MalwareBytes be run. I have used the free version before

and I downloaded the latest version from your website, installed it and tried to run it.  When I start the program running

nothing happens, then after a few seconds I receive a dialog


Run-time error '-2147024769 (8007007f)';
Automation error
The specified procedure could not be found.
This happens every time.
Can anyone advise me ?
Link to post
Share on other sites

Hello and :welcome:

Sorry to hear your having issues running Malwarebytes. This could be due to an infection or something else going on with your computer. Please run the tools below so we can review those logs and see if we can point you in the right direction.

Please run the tools below and ATTACH (do not copy and paste) the logs so someone can better assist you.

Please post an mbam-check log:

Create an mbam-check log:

  • Download mbam-check.exe from here and save it to your desktop
  • Double-click on mbam-check.exe to run it, it should then open a log file
  • Please attach the CheckResults.txt file which should now be located on your desktop to your next reply

Please run the following scanner and send back the logs.

Download DDS from one of the locations below and save to your Desktop



Temporarily disable any script blocker if your Anti-Virus/Anti-Malware has it.

How To Temporarily Disable Your Anti-virus, Firewall And Anti-malware Programs

Once downloaded you can disconnect from the Internet and disable your Ant-Virus temporarily if needed.

Then double click dds.scr or dds.com to run the tool

Click the Run button if prompted with an Open File - Security Warning dialog box.

A black DOS console should open and run for a moment.

  • When done, DDS will open two (2) logs:
    • DDS.txt
    • Attach.txt
  • Save both reports to your desktop
  • Please include the following logs in your next reply: DDS.txt and Attach.txt

    You can ignore the note about zipping the Attach.txt file in most cases.

Link to post
Share on other sites


I have rerun the two tools, this time ensuring that the antivirus (Comodo) is turned off, together with the firewall and the

sandboxing. I attach these new files.

I have now discovered that I cannot run IE8, failing with a message 


iexplore.exe - Ordinal not found

The ordinal 410 could not be located in the dynamic link library urlmon.dll.


A search for this using Agent Ransack gave the results in SearchResults.txt.

 I have also done a full system scan using a Comodo Rescue disk.

This scan gave a negative result, nothing found.





Link to post
Share on other sites

Thanks for the reply.

I don't know what happened, but after another couple of Windows updates from Microsoft, everything has started

working again. Help & Support and Malwarebytes run fine. 

Must have been something with the first lot of 140 updates.

Just ran full scan with Comodo, Malwarebytes and SAS with clean bill of health from all 3.

Hopefully that is  problem solved.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.