Jump to content
Sign in to follow this  
Mad Dog Vee

Formatted USB stick, can't paste to

Recommended Posts

I'm confused.

I removed a U3 garbage from a USB stick and then formatted it to NTFS. All that worked like a charm as far as I could tell.

However, now I cannot copy, cut or paste any files to it. What's the problem?

EDIT: Does it only work on the machine it was formatted on? As I formatted it on XP Pro, took it out, plugged it into Vista to copy stuff to it but access was always denied, no matter what I copied. I thought a run as admin was needed but couldn't find an option for it by right clicking the drive that usb stick was allocated.

EDIT 2: I think I'm starting to get it, that's how the security of the NTFS format of a USB stick works, nothing rogue can copy and I presume execute from it that way.

Feel free to help me out with a better explanation.

Share this post


Link to post
Share on other sites

Greetings MDV. Those U3 drives are tricky little devils. There's actually a special procedure to getting rid of the U3 partition. That could be why it's messed up now. To fix it, I'd try reinstalling U3 and then remove it properly. By default, Windows installations do not allow normal USB devices to auto-execute, so there's really no need to fear if your flash drive gets infected, as long as you right click it in explorer and select open so that you know you're browsing the files on the drive and not running anything. You can also create your own custom autorun.inf file in the root of the USB drive and make it read only to help prevent it being overwritten by flash drive infecting malware.

Share this post


Link to post
Share on other sites

Believe it or not I managed to get it working. I used the u3 uninstall tool to remove the u3 rubbish and then formatted it to NTFS.

Thankfully I have a copy of Total Commander, it seems I need admin rights to be able to copy to the USB stick now - at least on my Vista Home Basic machine. Total Commander allows me to do copying run as administrator.

On the XP Pro machine that I formatted it on, so far it appears I do not need anything. I'm thinking that is probably because I was logged in as an administrator though. I set it up with an admin and limited account. I normal use just the limited account.

Share this post


Link to post
Share on other sites

That's still odd, unless you somehow set the partition as read only or something. Of course, flash drives are normally formatted as FAT, not NTFS, so that could have something to do with it as well.

Share this post


Link to post
Share on other sites

Thank you. I thought it was odd too.

I changed it to NTFS for security purposes and have since presumed that NTFS requires admin privileges to copy to it.

At first I thought it was TeraCopy failing me with large file size of progs I wanted to copy but then a simple notepad.txt wouldn't work I knew something was up.

Then with the advantage of TotalCommander which provides me with a check box that says

"Copy NTFS permissions (may need administrator rights)"

which of course I tick and allow it all to proceed and it works fine.

I will check to see how it functions on my limited account on XP Pro and see if I need to go through the same steps.

In the meantime I will continue presume that NTFS requires admin privileges to copy or paste to it.

Share this post


Link to post
Share on other sites

Figures. I'd go FAT32 then, just for the convenience, but that's your call. Like I said, if you go by the MS KB article I posted, you can prevent anything from autorunning from any type of media (including CD's).

Share this post


Link to post
Share on other sites

I wanted this particular USB drive to be a bit more secure, but physically it strikes me as a whole lot more fragile.

Share this post


Link to post
Share on other sites

Hee hee, if you really want to make it invulnerable to attack you can put U3 back on then use a special tool someone developed for replacing the U3 partition with your own custom ISO (can't really talk much about it here as it's kinda hack-ish) then put the files you want on your custom ISO, and since Windows will see it as a CD-rom device, it will be totally read-only and therefore off limits to anything that tries to write to it. I did it with mine and replaced U3 with a custom image of Bart's PE.

Share this post


Link to post
Share on other sites

I'm actually trying to get my hands on a write protect usb stick, little slider or tab on it like the floppies used to have, but is proving difficult. It's an idea I'll keep in mind though E360

Share this post


Link to post
Share on other sites

It's definitely possible, I've made some enquiries and just waiting for some people to get back to me.

Share this post


Link to post
Share on other sites

Cool, any idea how it works? I know with floppies it worked the same way as VHS tapes, a tab that would normally push through the little hole lets it write to the disk, but if locked, it couldn't push through so it wouldn't write to it. With USB it seems it would have to be some strange sort of software means.

Share this post


Link to post
Share on other sites

I haven't seen one in person yet but my understanding is the same sort of floppy mechanism. There's a little slider you use that makes it write protect. Only ones that claim to be write protect USB seem to be some weird brand - PQI

Share this post


Link to post
Share on other sites

I've heard of PQI, they make Ram as well. A pretty good company from what I hear. You might find what model #'s have the write protection feature and do a search on newegg.

Share this post


Link to post
Share on other sites

PQI-U339-16GB

PQI-U339S-16GB

PQI-U339-2GB - the one I want to chase up

So basically anything in the U339 series

Share this post


Link to post
Share on other sites
Where are you from (if you don't mind me asking)?

Group: Honorary Members

Posts: 75

Joined: 7-December 08

From: Australia

That's down off the coast of New Zealand

Share this post


Link to post
Share on other sites

According to what I just read about new egg, unless I'm in Canada or China, there's not much point. The other two main New Egg sites.

Mind you I am awaiting some email responses about them from within this country.

Yeah Australia, that big land mass that prevents New Zealand from being invaded :(

Share this post


Link to post
Share on other sites

Also home to the dreaded funnel web spider. I hates me some spiders. Of course, where I live we have black widows, brown widows and brown recluses, but they aren't very aggressive (unlike the funnel web).

Share this post


Link to post
Share on other sites

Couldn't really see anything unfortunately. I'm still wondering how the heck it works. It doesn't seem to require any proprietary software or drivers to be installed (of course, it does come with U3 so perhaps that somehow ties into it's functionality).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.