Jump to content

Device cannot start Code 10

Recommended Posts

My latest testbox has now developed a problem. The previous one's HDD died (I posted here). I've lost wireless internet connection and device manager is giving me a code 10. The machine is an HP Compaq 6710b running Windows 7 Ultimate

(it came loaded with Vista Business). The Intel adapter is PRO/Wireless 3945ABG.

What I've tried;

System Restore, which got it back but only until I rebooted. Further restore then failed to resolve the problem.

HP diagnostics, which came up Pass.

HP Bios, restore default config settings.

Downloaded latest Intel install using their detection tool

The blue Led indicator is lit (a common mistake when cleaning the keyboard and bezel)

Is there anything else I can try or do I conclude that this is a hardware problem.


Link to post
Share on other sites

Thanks for your responses. Yes, Yes and Yes. Fixit is clear that it's a driver issue. There are a number of drivers stored for the device and I have gone through them uninstall/deleting the drivers until there are no drivers left that support the device. Reboot and it installs the same damned driver.

Link to post
Share on other sites

  • Root Admin

Highly suggest not using any type of "Driver Pack"

The WINDOWS\INF folder will contain the plug and play driver but I really think there is some type of resource conflict going on as I rarely seem to get the CODE 10 error if I have the right driver. It seems to only happen when one device is in conflict with another.

Is this a built-in card or an external add-in card?

Have you disconnected ALL other external devices except the keyboard and mouse?

Can you run a DDS report ?

What does the Event Logs say about it (if anything)

Link to post
Share on other sites

  • Root Admin

So say everyone on the Internet that offers packs and yet there are thousands of screwed up systems. I'm not saying this one does anything wrong, but for me it's just plain crazy to get drivers from any 3rd party when the MFG already has one. If the MFG no longer offers a driver or has gone out of business that's one thing but otherwise for me personally they're pretty much close to SPAM.

Link to post
Share on other sites

I only ever download drivers from the manufacturer, I even have the option to download driver updates from windows disabled. I think what has happened is that the driver has somehow become corrupted and every time I attempt to uninstall/delete the driver in order to install an updated package from Intel it is auto-installing the corrupt driver. I have tried to overcome this by disabling the auto-install feature (temporarily) by the following;

gpedit.msc>opening the Local Group Policy Editor> Computer Configuration->Administrative Templates->System->Device Installation>

Prevent Installation of Devices not described by other policy settings> edit and set it to enabled. I thought that was how you do it but it doesn't seem to have work. I will do the DDS scan when I've put my son to bed. Thanks for the help and suggestions everyone.

Link to post
Share on other sites

I agree with Ron. Best Practice dictates that one should ONLY get hardware drivers from the Vendor or the Manufacturer. For example an Intel NIC on a HP platform. Get the drivers from HP for the given platform or get them straight from Intel. No third parties.

The Intel PRO/Wireless 3945ABG is fairly common. It usually comes as a plug-in board and can be used by any platform manufacturer. The drivers also come stock with Vista and above (I can't say if it is also covered by Win8).


You stated...

"There are a number of drivers stored for the device and I have gone through them uninstall/deleting the drivers until there are no drivers left that support the device. Reboot and it installs the same damned driver."

If the driver is correct then I would then shutdown the NB and remove the card. There should be a trap door on the bottom of the notebook. One or two screws to hold it down and one or two wires connected to the WiFi NIC.

With the card removed, (replace the trap door or not) reboot the NB and go into Device Manager and see if Code 10 is still generated.

Since doing a System Restore, and assuming the drivers were corrupted, didn't bring back a working state then it is possible the WiFi NIC has failed.

Link to post
Share on other sites

I tried David's suggestion of removing the NIC and booting. The device wasn't showing in Device Manger but I ran the installer anyway. Windows made no attempt to interrupt. I re-fitted the NIC and rebooted. Success!!!

Thanks to everyone.......and David I owe you a large one.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.