Jump to content

Auto run from the hard drive and network....


ZeeBee
 Share

Recommended Posts

Hi

I went through all the options you gave me in the link and it still says on the Kaspersky Security Scan's report that it needs to be disabled. Could there be something enabling it on again that I need to disable first?

Thanks for your help and advice it's very much appreciated.

Link to post
Share on other sites

  • Root Admin

How to disable the Autorun functionality in Windows

The updates that this article describes fix a problem with the disable Autorun feature. Without these updates, Autorun for a network drive cannot be disabled. Also, the shortcut menu and double-click functionality of Autorun were not disabled even if the steps that were previously provided were followed. This problem is fixed by the updates described in this article. The updates were distributed to the following systems through the Windows Update and Automatic update distribution channels:

Microsoft Windows 2000

Windows XP Service Pack 2

Windows XP Service Pack 3

Windows Server 2003 Service Pack 1

Windows Server 2003 Service Pack 2

Prerequisites to disable Autorun capabilities

Autoplay and Autorun are two different features of Windows. Disabling Autoplay from Control Panel and making changes in Registry to set NoDriveTypeAutoRun key to FF does not change the Autorun behavior.

If windows perform any task automatically when you connect the external hard drive then we can say that Autoplay is enabled.

If nothing happens and only the Icon changes in windows explorer then Autoplay is disabled, we cannot stop windows from changing the icon because the behaviour is by design.

Please check the link below that discusses about Autoplay and Autorun,

http://windows.micro...lay-and-autorun

Using the Registry to Disable AutoRun

The NoDriveTypeAutoRun subkey value is reset to the original default value on a Windows Server 2003-based computer, on a Windows XP-based computer, or on a Windows 2000-based computer

It could also potentially be Kaspersky that is preventing the change according to this post.

Autoplay does not work

Link to post
Share on other sites

Hi

No every option I try it still remains on. The Kapersky software is an on demand scanner so I don't think it would have any effect. I have tried all the options again with no protection activated on the computer and its still not working, it's still reported as enabled.

I may try to re-installing the OS and try again as I cant see why it has no effect. Sorry it took a while to get back to you it's not my computer and I just help the old lady whose lappy it is so have to explain to her every time I help her out what I'm doing, she can just manage E-mail and copy and paste so far lol.

Thank you for all the help given its much appreciated Firefox and Ron.

Link to post
Share on other sites

Hi

Its Kaspersky Security Scan which I originally ran to help find why Trend Micro was reporting so many threats to pages the lady who owns the laptop has never been to. There's no malware shes clean as I've run OTL and some other tools. I'm of the thinking now that she may be experiencing some kind of man in the middle attack and that's why I would love to tighten up her PC for her. I'm no techy at all just been using PCs for about a year and a half but am learning quite a bit. If you'd like to close the post please do as I think I've done all I can I will reinstall the operating system and try your links to see if it will work on version 1 of vista and then install the other two vista updates sp1 and 2.

Sorry for the waffle and thanks for your kind help and your patience.

Zeebee

Link to post
Share on other sites

  • Root Admin

Well since it's Kaspersky that is saying this I would suggest probably creating a topic on their support site and seeking assistance from them.

Are you sure this computer is fully up to date with all of the prerequisite patches and updates as explained in the documentation?

Link to post
Share on other sites

Hi

When I tried the updates they said it didn't apply to her system. I keep her up to date as regards to updates for all other programs running on her PC.

I tried the Microsoft disable and enable tool on one of my laptops running the same OS and AV and they worked just fine for me so I'm guessing it must be something on her machine that's stopping the disable option.

I posted on the Kaperksy forum like you suggested and will wait for a reply from them.

Thank you very much for all your help :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.