Jump to content

TCP/IP protocol driver problem.


Recommended Posts

Hello forum.

Ive recently reinstalled my windows 7 OS.

And upon looking in device manager ive noticed an exclamation mark next to a driver.

Any ideas what i do here.uninstall update the driver etc.?I suspect it needs updating but im not too sure.

Ive enclosed a pic to explain what i mean.

Thank you.

post-110561-0-93997400-1347098090.png

Link to post
Share on other sites

I can only speak to my Windows and a Few others i have installed. Windows 7 seems to find most of the Drivers you needs within the first week of Installation. Printers did seem to be an exception but I had no sound at first, then after a Few Days, I got a Notice, New Drivers were being installed. I did update the Intel parts I have be going to:

http://www.intel.com/ > Support

And that seemed to help the process of getting updates. I did let Install their Active X App to scan my System.

Link to post
Share on other sites

Do you have the correct Drivers for your NIC Installed. You don't bother to mention the hardware you installed Windows 7 on, so I have to wonder if you checked with the manufacture to see if they have Drivers for your PC and Windows 7. I can only assume you did a Windows 7 Evaluation before you did the upgraded to know if everything on your system was compatible before moving forward with your upgrade. I see from what you did post, you are having Issues with the TCPIP Protocal and I have to wonder if you have cleared your TCP Stack? When I look Google TC{I{ Protocol Error Code 24. Microsoft reports the Following "If you have yellow "!"mark next to tcp/ip protocol driver - This device is not present, is not working properly, or does not have all its drivers installed. (Code 24)"

Most Site or replies that this is often more of a Windows XP Error but the Fix's are often the Same, Reset the Windsock

Method 1: Reset Winsock

Windows sockets settings may get corrupted due to the installation of networking software, or perhaps due to Malware infestation. Try resetting Winsock entries to its default installation.

Here’s how:

a. Click Start, select Run, type cmd and press Enter.

b. Type: netsh winsock reset catalog in the command prompt and press Enter.

Method 2: Reset TCP/IP stack to installation defaults.

TCP/IP can sometimes become damaged or corrupted. If you cannot connect to the Internet and you have tried the above method to resolve the problem, TCP/IP might be causing it.

Download and run the fix it from the link below.

How to reset Internet Protocol (TCP/IP)

http://support.microsoft.com/kb/299357

Method 3: You may download and install the latest drivers for network adapter device.

For more information, refer to the following articles and check:

How to manage devices in Windows XP

http://support.microsoft.com/kb/283658

Explanation of error codes generated by Device Manager in Windows XP Professional

http://support.microsoft.com/kb/310123

Link to post
Share on other sites

Hi Arnold72 :)

It would really help if you posted a picture of the driver properties window and gave us some info on the hardware you use.You can also download Speccy and post the snapshot(system info). Make sure you download the slim build! Otherwise it includes toolbars and other junk in the standard installer. ;)

http://www.piriform.com/speccy/builds

Link to post
Share on other sites
  • Root Admin

Please run the following scanner and send back the logs.

Download DDS from one of the locations below and save to your Desktop

dds.scr

dds.com

Temporarily disable any script blocker if your Anti-Virus/Anti-Malware has it.

How To Temporarily Disable Your Anti-virus, Firewall And Anti-malware Programs

Once downloaded you can disconnect from the Internet and disable your Ant-Virus temporarily if needed.

Then double click dds.scr or dds.com to run the tool, on Vista or Win 7 right click and select Run as administrator

Click the Run button if prompted with an Open File - Security Warning dialog box.

A black DOS console should open and run for a moment.


    When done, DDS will open two (2) logs:
  1. DDS.txt
  2. Attach.txt

  • Save both reports to your desktop
  • Please include the following logs in your next reply: DDS.txt and Attach.txt
    You can ignore the note about zipping the Attach.txt file in most cases.

Link to post
Share on other sites

hello .

Thank you for all the helpful replies.Ive managed to solve the problem by simply uninstalling the driver.Upon reboot the driver was reinstalled and thankfully there is no exclamation mark.

I realise uninstalling the driver was a brash action to take ,but upon research i decided to take the plunge and it worked,

As for the cause well im suspecting my comodo internet security may not have uninstalled correctly.

Thanks for all the help. :D:ph34r:

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.