Jump to content

Scheduler trouble


Recommended Posts

So I bought the paid version a few days ago, but unfortunately I can't get the scheduler to work correctly or reliably. I've tried uninstalling and reinstalling, uninstalling and then running MBAM-clean and reinstalling (rebooting when required) and yet still it will not work.

I've had updates work when set to 'realtime' or 'hourly' but 'Daily' scans and updates simply won't start. There's no indication in the logs that they ever attempted to. I'm running MSE (with exclusions set in both MSE and MBAM), MBAM Pro with the protection module enabled fully, and Windows 7 firewall control as my firewall. This is all on a Windows 7 x64 laptop.

*

For example, I just tried the uninstall - Mbam-Clean - Reinstall routine. I then set an update to run daily at 6:00PM and a scan at 6:30PM. Rebooted, logged in and waited. Mbam started with windows and yet it's now 6:46PM and MBAM has yet to scan or update. My log for today reads as follows:

2012/04/13 17:49:41 +1000 JAMES-PC James MESSAGE Starting protection

2012/04/13 17:49:43 +1000 JAMES-PC James MESSAGE Protection started successfully

2012/04/13 17:49:46 +1000 JAMES-PC James MESSAGE Starting IP protection

2012/04/13 17:49:46 +1000 JAMES-PC James MESSAGE IP Protection started successfully

2012/04/13 17:52:46 +1000 JAMES-PC James MESSAGE Starting protection

2012/04/13 17:52:50 +1000 JAMES-PC James MESSAGE Protection started successfully

2012/04/13 17:52:53 +1000 JAMES-PC James MESSAGE Starting IP protection

2012/04/13 17:52:54 +1000 JAMES-PC James MESSAGE IP Protection started successfully

I have no reason to suspect I'm infected (Fairly new laptop, kept it very clean, no piracy, so far no detected infections or attempted infections, or other behaviour that would indicate an infection). Manual scans and updates work like a charm.

Any clue what's going on here? I like the free version of MBAM but so far the paid version is being more trouble than it's worth. Hopefully I can get this sorted.

Link to post
Share on other sites

Hello, insomniac:

Sorry you are having scheduler troubles.

It has always worked fine for me, so I'm not an expert by any means.

Until an MBAM staffer arrives, you might want to take a look at the FAQ - Section O for help with the scheduler.

There is also a "recover if missed by..." setting that you might need to configure in order to get it to perform the way you wish (see attached screenshot).

Finally, starting with version 1.60, updates take place within 15 minutes of the scheduled time: http://www.malwareby...changelog#1.60.

So, if your update is scheduled for "6:00 PM", it might actually occur any time from 5:45 to 6:15.

(Also I think you need to be logged in to Windows as an adminstrator to set the scheduler. Perhaps try a right click on your desktop shortcut icon for MBAM and select "run as administrator" from the context menu and then proceed?)

HTH a bit,

daledoc1

post-29793-0-60006700-1334314206.png

Link to post
Share on other sites

Thanks, but I've messed around with the 'recover if missed' setting, and I'm logged on as an admin. I've now set it to update hourly, and it has indeed performed the scheduled update... However, it only performed it after two hours had elapsed, which seems odd. I might set a few different scan and update schedules and see which ones it follows through with.

Cheers.

Link to post
Share on other sites

UTC +10:00, synced from the internet.

The hourly updates seem to be working, so I've deleted that schedule and I will monitor the daily update and scan schedule for a few days to see what's happening. Oddly MSE missed its daily scan today, but it worked yesterday so I'm not sure it's a problem... I might have had my PC shut down when it was scheduled to go, I can't remember.

Link to post
Share on other sites

Well, knock me down with a feather. Both the update and the scan worked today, right on cue. These schedules were set yesterday. Perhaps the scheduler is starting one day after it's supposed to? I'll have to do more testing at a later date.

Oddly, though 'Terminate the program after a successful scan' is ticked, the MBAM interface remained after the scan completed.

What exactly is that checkbox meant to achieve?

Link to post
Share on other sites

I appreciate the follow-up to let me know everything is working well for you.

If you have any other questions or issues arise in the future please do not hesitate to create a new topic describing your issue in detail. A friendly forum helper will be glad to assist you.

Thank you very much! :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.