Jump to content

MBAM Pro not automagically starting in Win7 Pro

Recommended Posts

I would appreciate any pointers from anyone. I run MBAM Pro on several computers (yes, all paid licenses!) but this troublesome PC is my first personal one running Win 7 Pro. MBAM isn't starting automatically, but all my other programs are starting when Win comes up. In addition, when I do bring MBAM up manually and want to check on settings, it asks for a password. I don't remember setting one when I installed Win 7 but I entered the password I normally use for other programs and logons, which worked fine. My normal user, when starting up, is an administrator. Just in case, I did the right-click thing and said MBAM should run as Administrator but it made no difference in the startup. I still have to start it manually.

In the past on WinXP Pro I added MBAM to Startup but that wasn't necessary. So, now what should I do?

Thanks for your help.

-- Carole

Link to post
Share on other sites

Section Q

Malwarebytes Anti-Malware won't open on Windows XP but the computer is not infected:

From what I can see the above is #17 in your link and it doesn't mention Win7 on a delayed start. I did see that MBAM was set to start delayed in WinPatrol. However, MBAM never started, delay or not. I've tried it both ways. I'm not sure what to try next because the MBAM settings are all correct, the service is running, everything seems A-OK.

I appreciate any further help!



Link to post
Share on other sites

Hello again, here's a quote from the section I'm referring to in the FAQ:

ISSUE: The Malwarebytes' Anti-Malware tray icon takes a long time to load on Windows Vista or Windows 7

SOLUTION: This is quite normal and happens because in Vista and 7, Microsoft allows services to startup with a delay. Doing this with the Malwarebytes' Anti-Malware protection module helps to ensure that no conflicts occur during startup with your resident antivirus protection, allowing it to load before Malwarebytes' Anti-Malware does. If you wish to change this behavior, read on, though it is generally not recommended:

  • Click on the Start vista-7-start.png button and type services.msc and press Enter
  • Click Continue at the User Account Control prompt
  • Once the Services window opens, scroll down the list until you find MBAMService and double click on it
  • Click on the drop down menu next to Startup Type and select Automatic instead of Automatic (Delayed Start)
  • Click the Apply button and click on Ok
  • Close the Services control panel and restart your computer, the Malwarebytes' Anti-Malware tray icon should load up much earlier after logging into Windows now

Link to post
Share on other sites

Thank you everyone. I had already changed the startup to automatic and actually rebooted twice. I just went in and rebooted a 3rd time and lo-and-behold, miracle, MBAM is now working as it should. Don't know why the 3rd time worked but I'm not asking questions, just appreciating your tips and help. Thanks muchly. Y'all are so great!


-- Carole

Link to post
Share on other sites

No problem, I'm glad we were able to help :).

FYI, if you access the Scheduler at any point, it will reset the startup type for the service back to Automatic (Delayed Start), so if you change your scheduler at any point, be sure to set the service back to Automatic before you shut the system down, otherwise Malwarebytes Anti-Malware will start with the delay again.

Please contact us again if you have any additional questions or issues.

Thanks :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.