Jump to content

Extremely slow browsing


Recommended Posts

Hi,

For the past week or so, my browser(s) have very slow intermittently. On start-up the browser window comes up instantly, but the webpage takes an age to load. Then a few mintues later everything is fine...then another few minutes later the same malaise.

I tried IE, Chrome, Firefox...all of them have the same problem.

I am running Windows Vista home SP2

HP Pavillion dv6000

Thanks for any help!

Link to post
Share on other sites

Hi,

For the past week or so, my browser(s) have very slow intermittently. On start-up the browser window comes up instantly, but the webpage takes an age to load. Then a few mintues later everything is fine...then another few minutes later the same malaise.

I tried IE, Chrome, Firefox...all of them have the same problem.

I am running Windows Vista home SP2

HP Pavillion dv6000

Thanks for any help!

Just an idea / starting point but maybe your internet service provider is having issues, I would check your internet download speeds to see if your bandwidth is where it is suppose to be, you can run a speed test here.

http://www.speedtest.net

I just ran a speed test using the site and here was my result. 1633316994.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.